Excel Forum


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama



Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 04-01-2008, 14:44   #1
budget
 
Giriş: 15/08/2007
Şehir: Aydın
Mesaj: 22
Excel Vers. ve Dili:
MS Excel 2003, Türkçe
Varsayılan Ortalama Formülü

Merhabalar;

Aslında basit bir soru ama ben çözemedim. 12 ayın ortalamasını almak istiyorum ama bazı aylar "0" değerler var. "0"ları dikkate almadan ortalamayı nasıl alabilirim?

Örnek: Ocak-Aralık dönemi arasında A malını mayıs ayında 4, Temmuz ayında 20 birim aldıysam. 12 ayın ortalaması 24/12=2 çıksın istemiyorum. 24/2=12 çıksın istiyorum.

Sadece 1-2 çeşit mal/hizmet olsa, bunu el ile yapardım. Ama bir sürü kalem var

Saygılarımla
budget Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2008, 14:47   #2
Ali
 
Ali kullanıcısının avatarı
 
Giriş: 21/07/2005
Mesaj: 7,318
Excel Vers. ve Dili:
İş:Excel 2007-Türkçe Ev:Excel 2003-Türkçe
Varsayılan

Aşağıdaki linki inceleyiniz.

Ortalama Fonksiyonu Uygulamaları
Ali Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2008, 14:47   #3
feraset045
 
Giriş: 18/01/2007
Mesaj: 160
Excel Vers. ve Dili:
ofis 2003 xp türkçe
Varsayılan

örnek dosya ekleyin lütfen
feraset045 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2008, 14:59   #4
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Mesaj: 12,723
Excel Vers. ve Dili:
Excel, 2013 - İngilizce
Varsayılan

0'ı yok sayan ortalama formülü:

=AVERAGE(IF(A1:A10<>0,A1:A10,FALSE))
=ORTALAM(EĞER(A1:A10<>0;A1:A10;YANLIŞ))

Bu formülü CTRL+SHIFT tuşları basıl iken ENTER tuşu ile girmelisiniz.

.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2008, 15:05   #5
Ali
 
Ali kullanıcısının avatarı
 
Giriş: 21/07/2005
Mesaj: 7,318
Excel Vers. ve Dili:
İş:Excel 2007-Türkçe Ev:Excel 2003-Türkçe
Varsayılan

Alıntı:
Ali tarafından gönderildi Mesajı Görüntüle
Aşağıdaki linki inceleyiniz.

Ortalama Fonksiyonu Uygulamaları

Diğer alternatifler

1.)
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=ORTALAMAA(EĞER(A1:A10<>0;A1:A10))
CTRL+SHIFT+ENTER tuşlarına basarak dizi formülüne çevirin.



2.)
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=ORTALAMA(EĞER(A1:A10<>0;A1:A10))
CTRL+SHIFT+ENTER tuşlarına basarak dizi formülüne çevirin.



3)
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=TOPLA(A1:A10)/EĞERSAY(A1:A10;">0")

Sıfırdan küçük değerler hesabı katılıp toplamlar veri sayısına bölünecekse son formülü tercih edin.

Diğer durumlarda(Negatif değer içeren verilerde) dizi formülü hatalı hesaplama yapacaktır.
Ali Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-11-2008, 12:56   #6
ezkurtcan
 
Giriş: 21/06/2006
Mesaj: 25
Varsayılan farklı bir talep

Merhaba;
Ortalama hesaplarken satırlardaki sayıya kadar olan ilk sıfırlarıalmasını istemiyorum. yani tablodaki kırmızı işaretlileri.
Eklenmiş Dosyalar
Dosya Türü: xls Book1.xls (13.5 KB, 42 Görüntülenme)
ezkurtcan Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-11-2008, 13:28   #7
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Mesaj: 12,723
Excel Vers. ve Dili:
Excel, 2013 - İngilizce
Varsayılan

Alıntı:
ezkurtcan tarafından gönderildi Mesajı Görüntüle
Merhaba;
Ortalama hesaplarken satırlardaki sayıya kadar olan ilk sıfırlarıalmasını istemiyorum. yani tablodaki kırmızı işaretlileri.
Dosyanız ekte.

.
Eklenmiş Dosyalar
Dosya Türü: zip Book1(11).zip (1.8 KB, 71 Görüntülenme)
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-11-2008, 13:37   #8
taganaga
 
Giriş: 26/11/2008
Mesaj: 5
Excel Vers. ve Dili:
EXCEL2007
Varsayılan

ben sıfırları ortalamay katmasın istiyorum. bunları uygulayınca katmıyor ama say/0 hatası gösteriyor. bir türlü gideremedim bu sorunu
taganaga Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-11-2008, 13:40   #9
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Mesaj: 12,723
Excel Vers. ve Dili:
Excel, 2013 - İngilizce
Varsayılan

Alıntı:
taganaga tarafından gönderildi Mesajı Görüntüle
ben sıfırları ortalamay katmasın istiyorum. bunları uygulayınca katmıyor ama say/0 hatası gösteriyor. bir türlü gideremedim bu sorunu
Hangi formülden söz ettiğiniz anlaşılmıyor? Bir örnek dosya ekleyin. Bakalım.

.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 26-11-2008, 14:06   #10
taganaga
 
Giriş: 26/11/2008
Mesaj: 5
Excel Vers. ve Dili:
EXCEL2007
Varsayılan

Alıntı:
yurttas tarafından gönderildi Mesajı Görüntüle
Hangi formülden söz ettiğiniz anlaşılmıyor? Bir örnek dosya ekleyin. Bakalım.

.
tamam ekleyeyim
Eklenmiş Dosyalar
Dosya Türü: xls ders bazında II. kademe deneme takipp.xls (57.5 KB, 23 Görüntülenme)
taganaga Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 17:22


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.


Bahis Forum - Define - Çorlu Kamera - Çorlu Petek Temizleme - Site Yönetimi - TYPO3 Türkiye
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden