Aynı Değerleri Toplama Hk.

h5_2255

Altın Üye
Katılım
11 Kasım 2014
Mesajlar
36
Excel Vers. ve Dili
Microsoft Office 2019 Pro Türkçe
Merhaba,

Elimde bir excel dosyayı mevcut. Bu dosyadaki kişileri listeleyip, aynı olan kişi var ise onların değerlerini toplamam gerekiyor. Uzun bir süre uğraştım ancak çözüm bulamadım.

Tablo 1 Elimdeki listedir. Tablo 2 ise elimdeki listenin sadeleşmiş halini hazırlamam gerekiyor.

C3 ile C5 aynı tahise sahipler. diğerleri aynen yazılırken C3 ve C5 değerlerinin KOD 1 ve TUR1 kısımlarını virgül(,) ile birleştirmesi, Sayısal kısmının ise toplanması gerekmekte

232051

Altın üye olmayanlar için

Yardımlarınız için şimdiden teşekkür ederim.
 

Ekli dosyalar

h5_2255

Altın Üye
Katılım
11 Kasım 2014
Mesajlar
36
Excel Vers. ve Dili
Microsoft Office 2019 Pro Türkçe
varmıdır formül ile uygulayabileceğimiz biz çözümü
 

ÖmerFaruk

Altın Üye
Katılım
22 Ekim 2017
Mesajlar
2,822
Excel Vers. ve Dili
Ofis 365 Türkçe
Merhaba
B12 Tarih hücresine aşağıdaki formülü dizi olarak girin ve aşağı doğru çoğaltın
=EĞERHATA(İNDİS($D$5:$D$8;KAÇINCI(0;EĞERSAY($B$11:$B11;$D$5:$D$8);0));"")

Excel versiyonunuz uygun olduğu için aşağıdkai formüllerle diğer sütunları yapabilrisiniz
KOD sütunu için C12 ye girin ve aşağı doğru çoğaltın
=METİNBİRLEŞTİR(",";1;EĞER($D$5:$D$8=$B12;E$5:E$8;""))

Aynısını TUR yani D sütunu için yapın
=METİNBİRLEŞTİR(",";1;EĞER($D$5:$D$8=$B12;F$5:F$8;""))

SAYISAL sütunu zaten klasik ETOPLA
=ETOPLA($D$5:$D$8;$B12;$G$5:$G$8)
 
Üst