Bir hücre içerisinden parça almak / hücreyi belli ama tekrarlanan bir karakterden bölmek

Katılım
30 Ağustos 2016
Mesajlar
7
Excel Vers. ve Dili
2016 Türkçe
Merhabalar. Bir hard disk içerisindeki dosyaları tam yolları ile birlikte excele döktüm. Bu hücrelerden sadece dosya isimlerini uzantıları ile birlikte almak istiyorum. Yani A1 hücresinde dizin b1 hücresinde dosya adı olsun istiyorum. Normalde soldan ve bul fonksiyonları ile benzer işlemi farklı işlerde yapabiliyordum ancak burada sorunum bölmek için belirleyicinin tekrarlanıyor olması. Yardımlarınıza ihtiyacım var. örnek olarak;

/a/b/c/d/e/f.jpg
/asd/fasdg/sd/s/afs/gsgafsas.png
/b/s/aaa.tif

şeklindeki veriyi

/a/b/c/d/e ---> f.jpg
/asd/fasdg/sd/s/afs ---> gsgafsas.png
/b/s ---> aaa.tif

gibi bölmek istiyorum. Dizin yolları farklı klasör sayısına sahip olduğu için metni sütunlara dönüştür işlevsiz kalıyor. almak istediğim dosyaadı.uzantı verileri aynı sütunda kalmıyor.
 
Katılım
7 Nisan 2021
Mesajlar
6
Excel Vers. ve Dili
2016
Merhaba, buna benzer bir konuda yardıma ihtiyacım var ancak başarılı olamadım. Umarım doğru yere yazıyorumdur. Elimde şöyle bir metin var ve yaklaşık 20.000 satır buna benzer veri var ve 2 ayrı sütuna aşağıdaki gibi bir şey yazmak istiyorum.

"Istanbul - IA1 - ID1 - GE1 - GK1 - BU1 - IG1 - BZ1 - KU1 - VX1 - UA1 - PQ1 - HG1 - CV1 - Denizli"

Bir Sütuna: Bu metinlerin içinde "BZ1" varsa "Var",
Bir Diğer Sütuna: "BZ1"den önce "Istanbul" varsa "Ana Durak İstanbul" demek istiyorum. Aynı şekilde bir de;

Bir Sütuna: Bu metinlerin içinde "BZ1" varsa "Var",
Bir Diğer Sütuna: "BZ1"den sonra "Istanbul" varsa "Ana Durak İstanbul" demek istiyorum.

Yani aslında içinde "BZ1" noktası olan ve öncesinde "İstanbul" olanları ve içinde "BZ1" olan ve sonrasında "Istanbul" olanları tespit etmeye çalışıyorum. Acaba yardımcı olabilir misiniz? Şimdiden çok teşekkürler.
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
10,016
Excel Vers. ve Dili
İş : Ofis 365 - Türkçe
Ev: Ofis 365 - Türkçe
Aşağı
Merhaba, buna benzer bir konuda yardıma ihtiyacım var ancak başarılı olamadım. Umarım doğru yere yazıyorumdur. Elimde şöyle bir metin var ve yaklaşık 20.000 satır buna benzer veri var ve 2 ayrı sütuna aşağıdaki gibi bir şey yazmak istiyorum.

"Istanbul - IA1 - ID1 - GE1 - GK1 - BU1 - IG1 - BZ1 - KU1 - VX1 - UA1 - PQ1 - HG1 - CV1 - Denizli"

Bir Sütuna: Bu metinlerin içinde "BZ1" varsa "Var",
Bir Diğer Sütuna: "BZ1"den önce "Istanbul" varsa "Ana Durak İstanbul" demek istiyorum. Aynı şekilde bir de;

Bir Sütuna: Bu metinlerin içinde "BZ1" varsa "Var",
Bir Diğer Sütuna: "BZ1"den sonra "Istanbul" varsa "Ana Durak İstanbul" demek istiyorum.

Yani aslında içinde "BZ1" noktası olan ve öncesinde "İstanbul" olanları ve içinde "BZ1" olan ve sonrasında "Istanbul" olanları tespit etmeye çalışıyorum. Acaba yardımcı olabilir misiniz? Şimdiden çok teşekkürler.
Aşağıdaki formül A1 hücresinde hem Istanbul ve hem de BZ1 ifadeleri geçiyorsa "Ana Durak İstanbul" sonucunu verir, geçmiyorsa boş bırakır:

=EĞERHATA(EĞER(VE(BUL("Istanbul";A1)>0;BUL("BZ1";A1)>0);"Ana Durak İstanbul";"");"")
 
Katılım
7 Nisan 2021
Mesajlar
6
Excel Vers. ve Dili
2016
=EĞERHATA(EĞER(VE(BUL("Istanbul";A1)>0;BUL("BZ1";A1)>0);"Ana Durak İstanbul";"");"")

Çok teşekkürler ama bu tam olarak işimi görmüyor. Çünkü maalesef burada kalkış veya varış noktası istanbulsa her türlü tek bir sütuna yazıyor.
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
31,837
Excel Vers. ve Dili
Ofis 365 Tr-64 Bit
Ofis 2010 Tr-En 32 Bit
BZ1 için;

C++:
=EĞER(ESAYIYSA(MBUL("BZ1";A1));"Var";"Yok")
Önceki İstanbul için;

C++:
=EĞER(ESAYIYSA(MBUL("Istanbul";SOLDAN(A1;MBUL("BZ1";A1))));"Ana Durak Istanbul";"")
Sonraki İstanbul için;

C++:
=EĞER(ESAYIYSA(MBUL("Istanbul";A1;MBUL("BZ1";A1)));"Ana Durak Istanbul";"")
 
Katılım
7 Nisan 2021
Mesajlar
6
Excel Vers. ve Dili
2016
BZ1 için;

C++:
=EĞER(ESAYIYSA(MBUL("BZ1";A1));"Var";"Yok")
Önceki İstanbul için;

C++:
=EĞER(ESAYIYSA(MBUL("Istanbul";SOLDAN(A1;MBUL("BZ1";A1))));"Ana Durak Istanbul";"")
Sonraki İstanbul için;

C++:
=EĞER(ESAYIYSA(MBUL("Istanbul";A1;MBUL("BZ1";A1)));"Ana Durak Istanbul";"")



Çok teşekkür ediyorum tüm işim çözüldü resmen. Çok sağolun! :)
 
Katılım
7 Nisan 2021
Mesajlar
6
Excel Vers. ve Dili
2016
BZ1 için;

C++:
=EĞER(ESAYIYSA(MBUL("BZ1";A1));"Var";"Yok")
Önceki İstanbul için;

C++:
=EĞER(ESAYIYSA(MBUL("Istanbul";SOLDAN(A1;MBUL("BZ1";A1))));"Ana Durak Istanbul";"")
Sonraki İstanbul için;

C++:
=EĞER(ESAYIYSA(MBUL("Istanbul";A1;MBUL("BZ1";A1)));"Ana Durak Istanbul";"")




Merhaba Korhan Bey,

Bu formüllerdeki ilk formülde bir ufak değişikliğe daha gitmeliyim. Acaba yardımcı olabilir misiniz bana yine?

Elimde Istanbul - IZ1 - GK1 - Bursa yazan 4 satır var. her bir satırında nosu var. 1-2-3-4 şeklinde.

Daha önce
EĞER(ESAYIYSA(MBUL("IZ1";B3));"IZ1";EĞER(ESAYIYSA(MBUL("JQ1";B3));"JQ1";"-")) formülü ile içinde hem IZ1 hem de JQ1 varsa yazdırıyordum. Şimdi ise;

IZ1 veya JQ1 varsa diye yazdırabilir miyiz? Yani IZ1 varsa IZ1 yazsın, JK1 varsa JK1 yazsın. (İkisi de varsa ikisinden birini yazması yeterli)

Ayrıca "Satır No" sütununda sadece 1 olanı alsın. Çünkü aslında bunların 4'ü de aynı ve ben bir satırdaki IZ1'i veya JQ1'i bulmaya çalışıyorum ki aynı satırı 4 defa saymayayım.


Excel dosyası paylaşmayı başaramadım bu nedenle böyle yazdım.

Şimdiden çok teşekkürler.
 

Mahir64

Destek Ekibi
Destek Ekibi
Katılım
19 Nisan 2006
Mesajlar
5,524
Excel Vers. ve Dili
Excel 2013-Türkçe
Soruyu tam anlamadım.

Sayma işlemi B3:B6 arasında mı yapılacak? Yoksa satır satır mı yazacak?

Kod:
=EĞER(ESAYIYSA(MBUL("IZ1";B3));"IZ1";EĞER(ESAYIYSA(MBUL("GK1";B3));"GK1";"-"))
Kod:
=EĞER(EĞERSAY($B$3:$B$6;"*IZ1*")>0;"IZ1";EĞER(EĞERSAY($B$3:$B$6;"*GK1*")>0;"GK1"))
 
Katılım
7 Nisan 2021
Mesajlar
6
Excel Vers. ve Dili
2016
Soruyu tam anlamadım.

Sayma işlemi B3:B6 arasında mı yapılacak? Yoksa satır satır mı yazacak?

Kod:
=EĞER(ESAYIYSA(MBUL("IZ1";B3));"IZ1";EĞER(ESAYIYSA(MBUL("GK1";B3));"GK1";"-"))
Kod:
=EĞER(EĞERSAY($B$3:$B$6;"*IZ1*")>0;"IZ1";EĞER(EĞERSAY($B$3:$B$6;"*GK1*")>0;"GK1"))

Satır satır yazacak. bunun gibi 10.000 satır var. ama aslında 10.000 satır içinde de ilk 4 satır benim için aynı şeyi ifade ediyor. Bu nedenle her bir satırda Segment Sequence 1 olan ve Line Variation - LineVariationName IZ1 veya JQ1'se IZ1 veya JQ1 yazsın istiyorum.
 
Üst