Soru çokeğersay, çoketopla,toplaçarpım özet tablo

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
544
Excel Vers. ve Dili
2016&2019 TR
Ekteki çalışmada her personelin hangi göreve kaç kez gittiğini rapor almaya çalışıyorum ancak formülde bir yerlerde hata yapıyorum bu nedenle sonuç alamıyorum. Özet tablo ile yapılabilirse anlık güncelleme yapar mı özet tablo değilse formülle nasıl yapabilirim. Yardımlar için teşekkürler.
 

Ekli dosyalar

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
544
Excel Vers. ve Dili
2016&2019 TR
Yanıt için çok teşekkürler hocam. Aynı formülü defalarca kez yazdım sonuç alamamıştım. Çokeğersay ya da farklı bir fonksiyonla çözümü var mıdır zahmet olmazsa.
 

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
544
Excel Vers. ve Dili
2016&2019 TR
Çok teşekkürler hocam. Zihninize sağlık.
 

yanginci34

Altın Üye
Altın Üye
Katılım
6 Temmuz 2010
Mesajlar
1,309
Excel Vers. ve Dili
excel2013
Rica ederim dönüş yaptığınız için ben teşekkür ederim kolay gelsin.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
6,174
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
Personel isimleri sıralı gittiğinde sayın yanginci34 yöntemi olur.Personel isimleri sıralı gitmez veya atlama var ise aşağıdakı şekilde kullanınız.
rapor C3 hücresine kopyalayınız.Sağa ve aşağı doğru çoğaltınız.
Kod:
=EĞERSAY(KAYDIR(Plan!$C$2;KAÇINCI($B3;Plan!$B$3:$B$42;0);;;100);C$2)
 

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
544
Excel Vers. ve Dili
2016&2019 TR
Sıralı değil hocam plan sayfasındaki personelin yeri sürekli değişiyor. Rapor sayfasındaki formülleri sabitleyebilir miyiz acaba.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
6,174
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
Sıralı değil hocam plan sayfasındaki personelin yeri sürekli değişiyor. Rapor sayfasındaki formülleri sabitleyebilir miyiz acaba.
Verdiğim formüllerde Plan sayfasındaki personel isimlerinin yeri değiştiğinde ,ilgili personelleri bularak doğru işlem yapar.Plan sayfasındaki personel isimlerinin yer değiştirmesinden etkilenmez.Rapor sayfasında personel isimlerini sabitleye bilirsiniz.
 

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
544
Excel Vers. ve Dili
2016&2019 TR
Rapor sayfasını sabitledim ancak formül etkileniyor.
Kod:
=EĞERSAY(KAYDIR(Plan!$C$2;KAÇINCI($B3;Plan!$B$3:$B$42;0);;;100);C$2)
$B$42 olan kısım plan sayfasındaki personelin yeri değiştikçe değişiyor bu nedenle formül YOK hatası veriyor.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
6,174
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
Rapor sayfasını sabitledim ancak formül etkileniyor.
Kod:
=EĞERSAY(KAYDIR(Plan!$C$2;KAÇINCI($B3;Plan!$B$3:$B$42;0);;;100);C$2)
$B$42 olan kısım plan sayfasındaki personelin yeri değiştikçe değişiyor bu nedenle formül YOK hatası veriyor.
Sorunu anlamadım.Örnek dosya ekleyiniz.
 

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
544
Excel Vers. ve Dili
2016&2019 TR
hocam plan sayfasındaki kesme ve yer değiştirme işlerinden etkilenmesin istiyorum formül.
 

Ekli dosyalar

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
6,174
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
Aşağıdaki formülle deneyiniz.Üstteki formül 42.inci satıra kadar arıyor ve 42 satırdan sonra yazdıklarınızı bulamadığından hata veriyor.42 sayısını plan sayfasındaki satırınıza göre yazınız.
Kod:
=EĞERHATA(EĞERSAY(KAYDIR(Plan!$C$2;KAÇINCI($B3;Plan!$B$3:$B$100;0);;;100);C$2);"")
 
Son düzenleme:

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
544
Excel Vers. ve Dili
2016&2019 TR
Tamamdır hocam bu formülle hata gelmiyor. Vakit ayırdığınız için çok teşekkürler.
 

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
544
Excel Vers. ve Dili
2016&2019 TR
=EĞERHATA(EĞERSAY(KAYDIR(Plan!$C$2;KAÇINCI($B3;Plan!$B$3:$B$100;0);;;100);C$2);"")

Formülün renklendirilen kısmı kesme işleminden etkilenerek değişiyor. Kesme işleminden etkilenmemesinin çözümü var mıdır acaba?
Yardımlarınız için şimdiden teşekkürler iyi bayramlar.
 

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
544
Excel Vers. ve Dili
2016&2019 TR
Hocam sizden öncede denemiştim ama çözüme ulaşamadım. Formül hata vermiyor kullanımda ancak değer de getirmedi benim çözümlerde
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
27,779
Excel Vers. ve Dili
OFFICE 2019 PRO TR
Uyguladığınız formülü paylaşın kontrol edelim.
 

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
544
Excel Vers. ve Dili
2016&2019 TR
=EĞERHATA(EĞERSAY(KAYDIR(Plan!$C$2;KAÇINCI($B3;DOLAYLI(Plan!$B$3:$B$100;0));;;100);C$2);"")
Kullanımını bilmiyorum ama yanlış çıkarımda bulunarak bu şekilde hazırladım sanırım.
 
Üst