Çokeğersay "Değer" hatası döndürüyor

Allback

Altın Üye
Altın Üye
Katılım
21 Eylül 2011
Mesajlar
100
Beğeniler
1
Excel Vers. ve Dili
Excel 2019 - Türkçe
#1
Merhaba,

iki koşula göre veri saydırmak istiyorum ama ne yaptıysam olmadı.
Sürekli "Değer" hatası veya 0 veriyor.
Eğersay ile yaparsam sorun olmuyor ama çokeğersay fonksiyonu ile saydıramadım.
Yardımlarınızı rica ederim.

Dosyada açıklamaya çalıştım.
 

Ekli dosyalar

Katılım
8 Mart 2011
Mesajlar
13,044
Beğeniler
746
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#2
Merhaba.
Biraz dolambaçlı oldu ama aşağıdaki formülü AG2 hücresine uygulayıp, sağa ve aşağı doğru kopyalayın.
Formülün kısaltılabileceğini düşünüyorum ama şimdilik iş görecektir.
Varsayım: AF sütunundaki isimlerin, A26:AC75 alanında en fazla bir kez yer alır.
Rich (BB code):
=EĞERHATA(EĞERSAY(DOLAYLI(ADRES(TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SATIR($A$26:$AC$75)))-13;TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SÜTUN($A$26:$AC$75)))-1)&":"&ADRES(TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SATIR($A$26:$AC$75)))-6;TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SÜTUN($A$26:$AC$75)))-1));AG$1);0)
 

Allback

Altın Üye
Altın Üye
Katılım
21 Eylül 2011
Mesajlar
100
Beğeniler
1
Excel Vers. ve Dili
Excel 2019 - Türkçe
#3
Merhaba.
Biraz dolambaçlı oldu ama aşağıdaki formülü AG2 hücresine uygulayıp, sağa ve aşağı doğru kopyalayın.
Formülün kısaltılabileceğini düşünüyorum ama şimdilik iş görecektir.
Varsayım: AF sütunundaki isimlerin, A26:AC75 alanında en fazla bir kez yer alır.
Rich (BB code):
=EĞERHATA(EĞERSAY(DOLAYLI(ADRES(TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SATIR($A$26:$AC$75)))-13;TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SÜTUN($A$26:$AC$75)))-1)&":"&ADRES(TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SATIR($A$26:$AC$75)))-6;TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SÜTUN($A$26:$AC$75)))-1));AG$1);0)
Çok teşekkürler. Ben bunu hayatta yazamamazmışım.
Varsayımınız doğru, isimler en fazla bir kez yer alıyor.
 
Katılım
8 Mart 2011
Mesajlar
13,044
Beğeniler
746
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#4
Bu da alternatif olsun.
Bence böyle hem daha kısa hem de daha şık bir formül oldu.
Rich (BB code):
=EĞER(TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SATIR($A$26:$AC$75)))=0;0;EĞERSAY(KAYDIR($A$1;TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SATIR($A$26:$AC$75)))-14;TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SÜTUN($A$26:$AC$75)))-2;8;1);AG$1))
Rich (BB code):
=EĞERHATA(EĞERSAY(KAYDIR($A$1;TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SATIR($A$26:$AC$75)))-14;TOPLA.ÇARPIM(($A$26:$AC$75=$AF2)*(SÜTUN($A$26:$AC$75)))-2;8;1);AG$1);0)
 
Son düzenleme:
Katılım
8 Mart 2011
Mesajlar
13,044
Beğeniler
746
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#6
Son cevabıma eklediğim üçüncü alternatif ile formül daha da kısalmış oldu.
Şimdi içime sindi.
.
 

Allback

Altın Üye
Altın Üye
Katılım
21 Eylül 2011
Mesajlar
100
Beğeniler
1
Excel Vers. ve Dili
Excel 2019 - Türkçe
#9
@Ömer BARAN hocam,

Son bir isteğim olacak. Dosyadaki rapor sayfasında, diğer tüm sayfalardaki verileri yine çokeğersay ile saydırabiliyordum.
Şimdi sizin yazdığınız formül ile personel gerçekleşmelerini de saymak istiyorum ama yine beceremedim.

"Personel Raporu" sayfasında yine aynı şekilde, iki kritere göre saydırmak istiyorum.
Sizden ricam yazdığınız formülün açıklamasını da yapabilir misiniz?
Ben elimdeki formülün anlamını bilmediğim için, istediğim şeye uyarlayamadım...
 

Ekli dosyalar

Katılım
8 Mart 2011
Mesajlar
13,044
Beğeniler
746
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#10
Tekrar merhaba.

Sayfalarda AP1:AW1 hücrelerindeki sütun başlıklarının ve AO2:AO15 aralıklarındaki isim listelerinin Performans sayfasındakiyle
birebir aynı olduğu varsayımıyla aşağıdaki formülü Performans sayfası C2 hücresine uygulayıp sağa ve aşağı kopyalayarak sonuç alınabilir.
=TOPLA.ÇARPIM(TOPLA(DOLAYLI("'"&tarihler&"'!"&ADRES(SATIR();SÜTUN(A$1)+41))))
 

Allback

Altın Üye
Altın Üye
Katılım
21 Eylül 2011
Mesajlar
100
Beğeniler
1
Excel Vers. ve Dili
Excel 2019 - Türkçe
#11
Tekrar merhaba.

Sayfalarda AP1:AW1 hücrelerindeki sütun başlıklarının ve AO2:AO15 aralıklarındaki isim listelerinin Performans sayfasındakiyle
birebir aynı olduğu varsayımıyla aşağıdaki formülü Performans sayfası C2 hücresine uygulayıp sağa ve aşağı kopyalayarak sonuç alınabilir.
@Ömer BARAN hocam çok teşekkürler, formül çalıştı.
Vaktiniz varsa kısaca formülü açıklayabilir misiniz?
 
Son düzenleme:
Katılım
8 Mart 2011
Mesajlar
13,044
Beğeniler
746
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#12
Formüldeki ADRES işlevi kısmını, =ADRES(SATIR();SÜTUN(A$1)+41) şeklinde aynı hücrelere uygularsanız,
AP2 'den AW15'e kadar hücre adresleri elde edilmiş olur.
DOLAYLI işlevi üzerinden de tüm sayfalarda, adresini bulduğumuz hücrelerin TOPLAMı alınmış oluyor.
Formülün yapısı, zaten dosyanızdaki mevcut formüllerde kullanılan bir yapı. Benim eklediğim HEDEF hücreleri buldurmak oldu.
 
Üst