ÇOKEĞERSAY formül kısaltma

tamer42

Destek Ekibi
Destek Ekibi
Katılım
11 Mart 2005
Mesajlar
1,770
Excel Vers. ve Dili
Office 2013 İngilizce
Merhaba,

"C38:C100" hücre aralığında; "Kritik", "Major", "Minor" metinleri yazılı

Burada;
"Kritik" yazanları say *5
"Major" yazanları say *3
"Minor" yazanları say *2

için aşağıdaki formülü kısaltma imkanımız var mı?


=ÇOKEĞERSAY(D3:D100;"OK";C3:C100;"Kritik")*5

+ ÇOKEĞERSAY(D3:D100;"OK";C3:C100;"Major")*3
+ ÇOKEĞERSAY(D3:D100;"OK";C3:C100;"Minor")*2

teşekkürler,
iyi çalışmalar.
 

Ömer

Moderatör
Yönetici
Katılım
18 Ağustos 2007
Mesajlar
19,938
Excel Vers. ve Dili
2013-Türkçe
Merhaba,

Bu şekilde deneyin.
Kod:
=TOPLA(ÇOKEĞERSAY(D3:D100;"OK";C3:C100;{"Kritik";"Major";"Minor"})*{5;3;2})
 

Haluk

Özel Üye
Katılım
7 Temmuz 2004
Mesajlar
8,936
Excel Vers. ve Dili
32 Bit 2010 - İngilizce
Alternatif:

Kod:
=SUMPRODUCT((C$38:C$100={"Kritik"\"Major"\"Minor"})*(D$38:D$100="OK")*{5\3\2})

Türkçe Excel için, Sumproduct >> TOPLA.ÇARPIM

.
 

tamer42

Destek Ekibi
Destek Ekibi
Katılım
11 Mart 2005
Mesajlar
1,770
Excel Vers. ve Dili
Office 2013 İngilizce
Alternatif:

Kod:
=SUMPRODUCT((C$38:C$100={"Kritik"\"Major"\"Minor"})*(D$38:D$100="OK")*{5\3\2})

Türkçe Excel için, Sumproduct >> TOPLA.ÇARPIM

.
Sn Haluk,
Formül #YOK hatası verdi ama;
 

Ömer

Moderatör
Yönetici
Katılım
18 Ağustos 2007
Mesajlar
19,938
Excel Vers. ve Dili
2013-Türkçe
\ olan ayraçları ; olarak değiştirerek deneyin.
 
Üst