Çoktan seçmeli şekilde tabloya veri çekme

HsynAA

Altın Üye
Katılım
3 Mayıs 2017
Mesajlar
34
Beğeniler
5
Excel Vers. ve Dili
2010 türkçe
#1
Arkadaşlar Merhaba,
Biraz karmaşık bir dosyada bir formül kurmaya çalışıyorum, işin içinden de çıkamadım indis falan kullandım ama bir türlü beceremedim örnek dosyanın içerisinde ayrıntılı olarak yazdım böyle bir formül bilen var mı yardımcı olabilir misiniz ? Olamasanız da hiç sorun değil zaten bende yapamadım biraz karışı bir iş,
Zaman ayıran arkadaşlara çok çok teşekkür ediyorum.
 

Ekli dosyalar

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
24,064
Beğeniler
204
Excel Vers. ve Dili
OFFICE 2013-2016 PRO TR
#2
C4 hücresine uygulayıp deneyiniz.

Kod:
=TOPLA(KAYDIR(Data!$E$1;KAÇINCI($B4;Data!$E:$E;0)-1;ELEMAN($O$3;KAÇINCI(TARİH(SOLDAN(C$2;4);$P$3;1);Data!$E$1:$AO$1;0)-1;KAÇINCI(TARİH(SOLDAN(C$2;4);1;1);Data!$E$1:$AO$1;0)-1);;ELEMAN($O$3;1;$P$3)))
 

HsynAA

Altın Üye
Katılım
3 Mayıs 2017
Mesajlar
34
Beğeniler
5
Excel Vers. ve Dili
2010 türkçe
#3
Korhpost: 972599' Alıntı:
C4 hücresine uygulayıp deneyiniz.

Kod:
=TOPLA(KAYDIR(Data!$E$1;KAÇINCI($B4;Data!$E:$E;0)-1;ELEMAN($O$3;KAÇINCI(TARİH(SOLDAN(C$2;4);$P$3;1);Data!$E$1:$AO$1;0)-1;KAÇINCI(TARİH(SOLDAN(C$2;4);1;1);Data!$E$1:$AO$1;0)-1);;ELEMAN($O$3;1;$P$3)))
Maalesef Korhan bey olmadı formülde bir yerde c3 var ondan dolayımı anlamadım tam :(
 
Katılım
8 Mart 2011
Mesajlar
12,826
Beğeniler
604
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#4
Merhaba.
Aslında Sayın AYHAN'ın verdiği formül de aynı sonuçları veriyor.
Verilen formülü forum sayfasından kopyalayıp C4 hücresine yapıştırdığınızdan emin misiniz?
Beki de gerçek belgenizde C2, E2 ve G2 hücrelerinde, örnek belgedeki gibi bir başlık kullanmamışsınızdır.
Zira Sayın AYHAN'ın verdiği formül, yıl bilgisini, belirttiğim hücrelerden alıyor.

Ben de başlık bilgilerinden bağımsız bir alternatif vereyim.
Formülü C4 hücresine uygulayın ve aşağı doğru C8'e kadar kopyalayın,
ardından C4:C8 arasını kopyalayıp, diğer yılların sütunlarına yapıştırın.
=TOPLA(KAYDIR(Data!$A$1;KAÇINCI(G.T!$B4;Data!$E:$E;0)-1;ARA(SÜTUN();{3;5;7};{4;16;28})+EĞER($O$3=1;$P$3;1);;EĞER($O$3=1;1;$P$3)))
 
Son düzenleme:

HsynAA

Altın Üye
Katılım
3 Mayıs 2017
Mesajlar
34
Beğeniler
5
Excel Vers. ve Dili
2010 türkçe
#5
Merhaba.
Aslında Sayın AYHAN'ın verdiği formül de aynı sonuçları veriyor.
Verilen formülü forum sayfasından kopyalayıp C4 hücresine yapıştırdığınızdan emin misiniz?
Beki de gerçek belgenizde C2, E2 ve G2 hücrelerinde, örnek belgedeki gibi bir başlık kullanmamışsınızdır.
Zira Sayın AYHAN'ın verdiği formül, yıl bilgisini, belirttiğim hücrelerden alıyor.

Ben de başlık bilgilerinden bağımsız bir alternatif vereyim.
Formülü C4 hücresine uygulayın ve aşağı doğru C8'e kadar kopyalayın,
ardından C4:C8 arasını kopyalayıp, diğer yılların sütunlarına yapıştırın.
Teşekkür ettim Ömer Bey Korhan Beyede aynı zamanda oldu :) çok saolun
 
Katılım
8 Mart 2011
Mesajlar
12,826
Beğeniler
604
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#6
Kolay gelsin.
 
Üst