Dosya paylaşım kilidi sayısı aşıldı.Hatası alıyorum.

Orion1

Uzman
Uzman
Katılım
1 Mart 2005
Mesajlar
20,907
Beğeniler
194
Excel Vers. ve Dili
Win7 Home Basic TR 64 Bit

Ofis-2010-TR 32 Bit
#1
Merhabalar.
Aşağıdaki kodlar ile yaklaşık 36000 satırlı kayıtlı veriyi değiştiriyorum.KS6.Update
satırında aşağıdaki hatayı alıyorum.
Dosya paylaşım kilidi sayısı aşıldı.MaxLocksPerFile Kayıt defteri girdisini arttırın.
Sayın üstadlarımın ve arkadaşlarımın bu konuda önerisini bekliyorum.
Kod:
If KS6.RecordCount > 0 Then
        KS6.MoveFirst
        Do While Not KS6.EOF
                KS6("Blok") = ComboBox1.Value
                KS6("Daire") = TextBox1.Value
                KS6("Isim") = TextBox2.Value
                KS6.Update
            KS6.MoveNext
        Loop
    End If
 

Haluk

Özel Üye
Katılım
7 Temmuz 2004
Mesajlar
7,061
Beğeniler
475
Excel Vers. ve Dili
32 Bit 2010 - İngilizce
#2
Bilgisayarınız size ne yapmanız gerektiğini söylemiş zaten ....

Kayıt defterinden ilgili anahtarın değerini arttırmanız gerekiyor.

Bu iş için, kayıt defterinde ( yani registry'de) aşağıdaki anahtarı bulun;

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.5\Engines\Jet 3.5

Ekranın sağ tarafında MaxLocksPerFile değerini değiştirmeniz gerekiyor. Bu anahtarı seçip, sağ tıklayın ve çıkan menüden modify - değiştir 'i seçip burada "decimal" seçeneğini seçin ve kutudaki değeri değiştirin.
 

Orion1

Uzman
Uzman
Katılım
1 Mart 2005
Mesajlar
20,907
Beğeniler
194
Excel Vers. ve Dili
Win7 Home Basic TR 64 Bit

Ofis-2010-TR 32 Bit
#3
Teşekkür

Merhabalar.
Sayın hocam:İşlem tamamdır.Değer 9500'e ayarlıymış.
Yardımınız için teşekkürler ederim.Saygılar sunarım.:hey:
 

acar6783

Altın Üye
Katılım
6 Temmuz 2008
Mesajlar
1,704
Beğeniler
18
Excel Vers. ve Dili
OFFİCE 2007- TÜRKÇE
#4
Bilgisayarınız size ne yapmanız gerektiğini söylemiş zaten ....

Kayıt defterinden ilgili anahtarın değerini arttırmanız gerekiyor.

Bu iş için, kayıt defterinde ( yani registry'de) aşağıdaki anahtarı bulun;

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.5\Engines\Jet 3.5

Ekranın sağ tarafında MaxLocksPerFile değerini değiştirmeniz gerekiyor. Bu anahtarı seçip, sağ tıklayın ve çıkan menüden modify - değiştir 'i seçip burada "decimal" seçeneğini seçin ve kutudaki değeri değiştirin.
Accesde coklu kayıt silmeye çalıştığımda aynı hatayı alıyorum fakat cevapa ne yazdığını anlayamadım ):
 
Katılım
5 Kasım 2006
Mesajlar
315
Beğeniler
16
Excel Vers. ve Dili
TÜRKCE Excel 2016
#5
Accesde coklu kayıt silmeye çalıştığımda aynı hatayı alıyorum fakat cevapa ne yazdığını anlayamadım ):

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.5\Engines\Jet 3.5 bu çıkmadı bende gifi takip ederseniz hedefe ulaşırsınız sanırım.
 

tugkan

Altın Üye
Katılım
6 Kasım 2004
Mesajlar
165
Beğeniler
44
Excel Vers. ve Dili
Excel 2016
Türkçe 64 BIT
#6
Sayın @acar6783
Cevap aşağıdadır.
Bilgisayarınız size ne yapmanız gerektiğini söylemiş zaten ....

Kayıt defterinden ilgili anahtarın değerini arttırmanız gerekiyor.

Bu iş için, kayıt defterinde ( yani registry'de) aşağıdaki anahtarı bulun;

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.5\Engines\Jet 3.5

Ekranın sağ tarafında MaxLocksPerFile değerini değiştirmeniz gerekiyor. Bu anahtarı seçip, sağ tıklayın ve çıkan menüden modify - değiştir 'i seçip burada "decimal" seçeneğini seçin ve kutudaki değeri değiştirin.
 

acar6783

Altın Üye
Katılım
6 Temmuz 2008
Mesajlar
1,704
Beğeniler
18
Excel Vers. ve Dili
OFFİCE 2007- TÜRKÇE
#7
Teşekkürler,
Silme işlemini döngü ile yapınca o hatayı almıştım fakat aşağıdaki kodlarla sorunumu çözdüm .

Kod:
Sorgu2 = "DELETE * FROM GiderRaporu WHERE YIL & '" & "|" & "' & AY = '" & Key & "' "

        Con.Execute (Sorgu2)
 
Üst