• DİKKAT

    DOSYA İndirmek/Yüklemek için ÜCRETLİ ALTIN ÜYELİK Gereklidir!
    Altın Üyelik Hakkında Bilgi

  • MÜJDE!!!! EXCEL WEB TR Adminlerinden Online EXCEL Seminerleri

    Online eğitimlere başlamadan önce sizlerin görüşlerini almak istiyoruz. Lütfen aşağıdaki konuda görüşlerinizi paylaşır mısınız... TEŞEKKRÜR EDERİZ

    ONLİNE EĞİTİM ANKETİ

Eğer ve Ve Deyimlerini Aynı Anda Kullanmak

ahmed_ummu

Altın Üye
Katılım
28 Mart 2011
Mesajlar
60
Excel Vers. ve Dili
Excel 2013Türkçe
Merhaba arkadaşlar.

Eğer ve Ve Deyimlerini aşağıdaki gibi aynı anda kullanmak istiyorum. Sonuç "DOĞRU" yazıyor.
Yapmak istediğim ise B12 hücreti dolu ve C11 hücresinin değeri 1 ise hücreye 2 yazdırmak istiyorum. Yardımcı olursanız sevinirim.

=EĞER(B12="";"";VE(C11=1;2))
 

1Al2Ver

Altın Üye
Katılım
5 Kasım 2007
Mesajlar
4,387
Excel Vers. ve Dili
Microsoft Office 365
Merhaba,

Sorunuzu yanlış anlamadım ise;

=EĞER(VE(B12<>"";C11=1);2;"")
 

Necdet

Moderatör
Yönetici
Katılım
4 Haziran 2005
Mesajlar
13,474
Excel Vers. ve Dili
Ofis 365 Türkçe
Buyrun :

Kod:
=EĞER(VE(B12<>"";C11=1);2;"Sonuç Yanlış")
 

1Al2Ver

Altın Üye
Katılım
5 Kasım 2007
Mesajlar
4,387
Excel Vers. ve Dili
Microsoft Office 365
Merhaba,

Hata vermemesi gerekir, Sayın Necdet'in formülü ile aynı formül,

Ben ; Eğer B12 boş değilse ve C11=1 ise 2 yaz, değilse boş bırak (boş bırak koşulu ; siz koşul gerçekleşmediğinde hücrede ne olmasını istediğinizi söylemediğiniz için),

=EĞER(VE(B12<>"";C11=1);2;"")

Necdet bey ; Eğer B12 boş değilse ve C11=1 ise 2 yaz, değilse "Sonuç Yanlış" yaz,

=EĞER(VE(B12<>"";C11=1);2;"Sonuç Yanlış")

şeklinde bir kurgu yaptık...

Teşekkür ederim.
 

ahmed_ummu

Altın Üye
Katılım
28 Mart 2011
Mesajlar
60
Excel Vers. ve Dili
Excel 2013Türkçe
Kusura bakmayın arkadaşlar. Formülün devamı olacağı için C11 in değeri rakam olunca hata veriyor. Aşağıdaki formül gibi yapmak istiyorum,

C11'in değeri "Pazartesi" ise 2, "Salı" ise 3, "ÇArşamba" ise 2, "Persembe" ise 3, "Cuma" ise 2 yazmasını istiyorum.

EĞER(VE(B12<>"";C11="Pazartesi");2;VEYA(c11="Salı");3;VEYA(C11="Çarşamba");2;VEYA(C11="Perşembe");3;VEYA(C11="Cuma");2;"")

C11 in değer hep "Pazartesi" olarak kalmayacak.
 

byfika

Altın Üye
Altın Üye
Katılım
15 Ağustos 2009
Mesajlar
476
Excel Vers. ve Dili
OFFICE 2016 Tr
Deneyiniz:
=EĞER(VE(B12<>"";C11="Pazartesi");2;EĞER(VE(B12<>"";C11="salı");3;EĞER(VE(B12<>"";C11="çarşamba");2;EĞER(VE(B12<>"";C11="perşembe");3;EĞER(VE(B12<>"";C11="cuma");2;"Sonuç yanlış")))))
 

Necdet

Moderatör
Yönetici
Katılım
4 Haziran 2005
Mesajlar
13,474
Excel Vers. ve Dili
Ofis 365 Türkçe
Merhaba,

Böyle durumlarda formülü EĞER fonksiyonu ile uzatmak pratik bir çözüm değil. Bunun yerine bir tablo hazırlayarak oradan DÜŞEYARA fonksiyonunu kullanabilirsiniz.
 

Ekli dosyalar

1Al2Ver

Altın Üye
Katılım
5 Kasım 2007
Mesajlar
4,387
Excel Vers. ve Dili
Microsoft Office 365
Merhaba,

Şöyle de olabilir ;

Kod:
=EĞERHATA(EĞER(VE(YADA($C$11="Pazartesi";$C$11="Çarşamba";$C$11="Cuma");$B$12<>"");2;EĞER(VE(YADA($C$11="Salı";$C$11="Perşembe");$B$12<>"");3));"YANLIŞ")
 

Necdet

Moderatör
Yönetici
Katılım
4 Haziran 2005
Mesajlar
13,474
Excel Vers. ve Dili
Ofis 365 Türkçe
Böyle de olabilir.

Kod:
=EĞER(B12<>"";ARA(C11;{"Cuma"\"Çarşamba"\"Pazartesi"\"Perşembe"\"Salı"};{2\2\2\3\3}))
 
Üst