• FORUMU MOBİL UYGULAMADAN TAKİP EDİN

    Forumu isteyen üyelerimiz Tapatalk (Harici bir hizmet) üzerinden mobil uygulamadan takip edebilirler.
    iOS için : https://itunes.apple.com/app/id307880732?mt=8
    Android için : https://play.google.com/store/apps/details?id=com.quoord.tapatalkpro.activity
    adreslerinden indirebilirsiniz.

    Bir iki haftaya da foruma özel kendi uygulamamız yayında olacak.
ALTIN ÜYELİK Hakkında Bilgi
-----------------------

Listenin Son 3 Rakamına Göre E topla Oluşturma

Katılım
3 Mayıs 2017
Mesajlar
20
Beğeniler
2
Excel Vers. ve Dili
2010 türkçe
#1
Arkadaşlar Günaydın,

Elimde 10 haneli rakamlardan oluşan bir liste var ve son 3 hanesi benim için mağaza kodunu ifade ediyor. Bu listeden son hanesini alarak başka bir listeye etopla yapmak istiyorum. Tabi birde ay kırılımı var. bunun için kullanabileceğimiz bir formül var mı bildiğiniz.
 

Ekli dosyalar

Ömer

Moderatör
Yönetici
Katılım
18 Ağustos 2007
Mesajlar
19,281
Beğeniler
46
Excel Vers. ve Dili
2010-Türkçe
#2
Merhaba,

L3:

=TOPLA.ÇARPIM((SAĞDAN($B$3:$B$159;3)=$J3&"")*(C$3:C$159))

.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
3,174
Beğeniler
272
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#4
Alternatif olarak.
Kod:
=TOPLA.ÇARPIM((ESAYIYSA(BUL($J3;$B$3:$B$300))*($C$2:$H$2=L$2)*($C$3:$H$300)))
 

Ömer

Moderatör
Yönetici
Katılım
18 Ağustos 2007
Mesajlar
19,281
Beğeniler
46
Excel Vers. ve Dili
2010-Türkçe
#5
Sayın çıtır,

bul fonksiyonunu bu şekilde kullanırsanız aranan değerin konumuna bakmadan işleme alır.

Örnek;

26101102 listede bu şekilde bir veri olsaydı içinde 101 olduğu için son 3 rakamı şartına bakmadan 101 olarak toplama dahil edecektir.

Bu mantıkla yapı aşağıdaki gibi kullanılabilir.

MBUL("?????"&$J3

.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
3,174
Beğeniler
272
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#6
Sayın Ömer;
Örneklerde sorun oluşturan bir durum görmediğimden kullandım.Uyarınız ve bilgilendirmeniz için çok teşekkür ederim.İstifade ettiğimi belirtmek isterim.Teşekkürler.
 
Katılım
3 Mayıs 2017
Mesajlar
20
Beğeniler
2
Excel Vers. ve Dili
2010 türkçe
#7
Sayın çıtır,

bul fonksiyonunu bu şekilde kullanırsanız aranan değerin konumuna bakmadan işleme alır.

Örnek;

26101102 listede bu şekilde bir veri olsaydı içinde 101 olduğu için son 3 rakamı şartına bakmadan 101 olarak toplama dahil edecektir.

Bu mantıkla yapı aşağıdaki gibi kullanılabilir.

MBUL("?????"&$J3

.
Ömer Bey ; Ben ki evde yaptığım yemeğin dönüp, tuzuna bile bakmaz iken acaba attım mı diye, sen daha önce cevap verdiğin bir konuda, başka biri cevap veriyor ve verdiği cevaptaki küçük bir ayrıntının aslında doğru sonuca ulaştırmayacağını dönüş yapıyorsun ... Helal olsun gerçekten, Saygı duyuyorum size. İyi çalışmalar.
 
Üst