• DİKKAT

    DOSYA İndirmek/Yüklemek için ÜCRETLİ ALTIN ÜYELİK Gereklidir!
    Altın Üyelik Hakkında Bilgi

  • MÜJDE!!!! EXCEL WEB TR Adminlerinden Online EXCEL Seminerleri

    Online eğitimlere başlamadan önce sizlerin görüşlerini almak istiyoruz. Lütfen aşağıdaki konuda görüşlerinizi paylaşır mısınız... TEŞEKKRÜR EDERİZ

    ONLİNE EĞİTİM ANKETİ

Makro ile Birden Fazla Şarta Bağlı Değer Yazdırma

cedi007

Altın Üye
Katılım
4 Nisan 2018
Mesajlar
56
Excel Vers. ve Dili
Office 365 - İngilizce
Selamlar,

Bir konuda desteğinize ihtiyacım var. Müsait olup da yardımcı olabileceklere şimdiden teşekkür ederim.
Sorum şöyle;
Tabloda olduğu gibi; A sütunundaki değerim 2T olduğunda, B2 sütunundaki değerin baştan ilk iki hanesi harf ile başlıyorsa, C2 sütununa yazsın.

Dosya ektedir.
 

Ekli dosyalar

ÖmerFaruk

Altın Üye
Katılım
22 Ekim 2017
Mesajlar
2,302
Excel Vers. ve Dili
Ofis 365 Türkçe
=EĞER(VE(A2="2T";DEĞİL(ESAYIYSA(1*PARÇAAL(B2;1;1)));DEĞİL(ESAYIYSA(1*PARÇAAL(B2;2;1))));B2;"")
 

ÖmerFaruk

Altın Üye
Katılım
22 Ekim 2017
Mesajlar
2,302
Excel Vers. ve Dili
Ofis 365 Türkçe
C++:
Sub Cedi007()
Dim xRng As Range
For i = 2 To 6
    Set xRng = Range("A" & i)
    If xRng = "2T" And xRng.Offset(, 1) Like "[A-Z][A-Z]*" Then
        xRng.Offset(, 2) = xRng.Offset(, 1)
    Else
        xRng.Offset(, 2) = ""
    End If
Next i
End Sub
 
Üst