Makro ile birden fazla şarta göre koşullu biçimlendirme

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
528
Excel Vers. ve Dili
2016&2019 TR
Makro ile koşullu biçimlendirme yapabiliyorum. Ancak benim yapabildiğim tek koşullu biçimlendirme. Örneğin G3="sarı" ise kırmızıya boya gibi. G3="pembe" ise yeşile boya. Q=>BUGÜN() ise siyaha boya gibi bunları tek tek makro biçimlendirme yapmak yerine tek bir kodun içerisine hepsini yerleştirebilir miyim?
Şimdiden teşekkürler.
 

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
528
Excel Vers. ve Dili
2016&2019 TR
Daha başka bir soru sorayım. Koşullu biçimlendirme yaptığımızda sayfada her yapılan kopyala yapıştır da koşullu biçimlendirme de kopyalanıyor.
Her ne kadar veri yapıştır kullansam da ortak dosya olduğu için bunun önüne geçemiyorum. Koşullu biçimlendirmeyi makroya atadığım zaman ise makronun her çalışmasında koşullu biçimlendirme penceresinde aynı makro koşulundan bir daha ekleniyor. Bunların dosyayı yavaşlatma gibi bir etkisi olur mu? Ve bu koşullu biçimlendirmenin sürekli çoğalmasının önüne geçebilir miyiz?
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
25,351
Excel Vers. ve Dili
OFFICE 2019 PRO TR
Sayfada bulunan koşullu biçimlendirmeleri ilk önce silerseniz sorununuz çözümlenecektir.
 

tukayf

Altın Üye
Katılım
9 Eylül 2010
Mesajlar
528
Excel Vers. ve Dili
2016&2019 TR
Makrolari calsitirmadan tum kosullu bicimlendirme sartlarini temizleyin mi demek istiyorsunuz hocam.

LG-H815 cihazımdan Tapatalk kullanılarak gönderildi
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
25,351
Excel Vers. ve Dili
OFFICE 2019 PRO TR
Eğer siz makronuzu her çalıştırdığınızda koşullu biçimlendirmeler artarak devam ediyorsa, ilk önce eski biçimlendirmeleri silmeniz (temizlemeniz) gerekecektir.
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
66
Excel Vers. ve Dili
TÜRKÇE
Biçimlendirme için makro oluşturmak istiyorum ama sütünü makro kaydedemiyorum

=EĞERSAY($A1:$Q1;"İPTAL")>0

=$A:$Q

=EĞERSAY($A1:$Q1;"HAS")>0

=$A:$Q

=YADA(HÜCRE("row")=SATIR())

=$A:$Q
 

Ekli dosyalar

Üst