Soru Sayı Genel Biçimlendirme (milyon,milyar)

MESUT K

Altın Üye
Katılım
26 Nisan 2019
Mesajlar
111
Excel Vers. ve Dili
İş'te:Excel 2007 eng
Ev'de:Excel 2010 tr
Herkese Merhaba
Ekteki excel dosyasında hücreye 1.000.000 yazdığımda 1 Milyon,1.000.000.000 yazdığımda 1 Milyar şeklinde yazması istiyorum.Yardımcı olabilirseniz çok memnun olurum.
Saygılarımla
 

Ekli dosyalar

Seyit Tiken

Uzman
Uzman
Katılım
23 Ağustos 2005
Mesajlar
4,075
Excel Vers. ve Dili
Excel : 2010
Diğerlerini siz yaparsınız.
Kod:
Private Sub Worksheet_Change(ByVal Target As Range)
If Target = 1000 Then Target = "BİN"
If Target = 10000 Then Target = "10 BİN"
If Target = 100000 Then Target = "100 BİN"
End Sub
 

Seyit Tiken

Uzman
Uzman
Katılım
23 Ağustos 2005
Mesajlar
4,075
Excel Vers. ve Dili
Excel : 2010
Yeni fark ettim, Excel'e Yeni Başlayanlar bölümüne sorulmuş.
Fomül :
Kod:
=DÜŞEYARA(C11;B2:C8;2;0)
 

Ekli dosyalar

MESUT K

Altın Üye
Katılım
26 Nisan 2019
Mesajlar
111
Excel Vers. ve Dili
İş'te:Excel 2007 eng
Ev'de:Excel 2010 tr
Diğerlerini siz yaparsınız.
Kod:
Private Sub Worksheet_Change(ByVal Target As Range)
If Target = 1000 Then Target = "BİN"
If Target = 10000 Then Target = "10 BİN"
If Target = 100000 Then Target = "100 BİN"
End Sub

makro istediğim sorunun karşılığı aslında.kodlar her hücrede çalışacak şekilde ayarlı sanırım fakat kodlar çalışmıyor
 

MESUT K

Altın Üye
Katılım
26 Nisan 2019
Mesajlar
111
Excel Vers. ve Dili
İş'te:Excel 2007 eng
Ev'de:Excel 2010 tr
Bu sefer çalıştı.Çok teşekkürler.(y)

Şöyle bir sorunum var.Aşağıda eklediğim dosya uyarladığım zaman sayısal değeri yok oluyor.Bakabilirseniz çok memnun olurum.
 

Ekli dosyalar

Seyit Tiken

Uzman
Uzman
Katılım
23 Ağustos 2005
Mesajlar
4,075
Excel Vers. ve Dili
Excel : 2010
Sıfır çıkan hücrelerdeki Sayı Biçimini bu şekilde yapın > #.##0,00 "kg"
 

MESUT K

Altın Üye
Katılım
26 Nisan 2019
Mesajlar
111
Excel Vers. ve Dili
İş'te:Excel 2007 eng
Ev'de:Excel 2010 tr
güncel
 
Üst