• FORUMU MOBİL UYGULAMADAN TAKİP EDİN

    Forumu isteyen üyelerimiz Tapatalk (Harici bir hizmet) üzerinden mobil uygulamadan takip edebilirler.
    iOS için : https://itunes.apple.com/app/id307880732?mt=8
    Android için : https://play.google.com/store/apps/details?id=com.quoord.tapatalkpro.activity
    adreslerinden indirebilirsiniz.

    Bir iki haftaya da foruma özel kendi uygulamamız yayında olacak.
ALTIN ÜYELİK Hakkında Bilgi
-----------------------

Tabloya göre fiyat listesi hesaplama

relaxim

Altın Üye
Altın Üye
Katılım
30 Ağustos 2009
Mesajlar
119
Beğeniler
6
Excel Vers. ve Dili
ofis 2010
#1
Arkadaşlar merhaba,

Ekte gönderdiğim örnekte açıklamaya çalıştım. Formül konusunda yardımcı olmanızı rica edeceğim.
 

Ekli dosyalar

Ali

Özel Üye
Katılım
21 Temmuz 2005
Mesajlar
7,429
Beğeniler
15
Excel Vers. ve Dili
İş:Excel 2013-Türkçe
Ev:Excel 2010-Türkçe
#2
D3 hücresine

Kod:
=EĞER(ARA(9,99999999999999E+307;--SOLDAN(B3;SATIR($1:$1024)))<=12;İNDİS($O$3:$O$8;KAÇINCI(C3;$R$3:$R$8;0));İNDİS($O$10:$O$15;KAÇINCI(C3;$R$10:$R$15;0)))
yazıp aşağı doğru çekiniz.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
3,174
Beğeniler
272
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#3
Alternatif olarak.
Kod:
=EĞER(SOLDAN(YERİNEKOY($B3;"x";"X");BUL("X";YERİNEKOY($B3;"x";"X"))-1)*1<=12;İNDİS($O$3:$O$8;KAÇINCI($C3;$R$3:$R$8;0))*$C3;İNDİS($O$10:$O$15;KAÇINCI($C3;$R$10:$R$15;0))*$C3)
 
Son düzenleme:

relaxim

Altın Üye
Altın Üye
Katılım
30 Ağustos 2009
Mesajlar
119
Beğeniler
6
Excel Vers. ve Dili
ofis 2010
#5
Arkadaşlar cevaplarınız için teşekkürler. Ellerinize sağlık. B sütunu gerekirse x ten önceki hali ile (16x2 yerine 16) yazabilirim. Bunu şunun için yazdım; formül gereksiz yere uzamasın daha basit olsun diye.... Formülü sadeleştirebilir miyiz?
 

Ali

Özel Üye
Katılım
21 Temmuz 2005
Mesajlar
7,429
Beğeniler
15
Excel Vers. ve Dili
İş:Excel 2013-Türkçe
Ev:Excel 2010-Türkçe
#6
Kod:
=EĞER(B3<=12;İNDİS($O$3:$O$8;KAÇINCI(C3;$R$3:$R$8;0));İNDİS($O$10:$O$15;KAÇINCI(C3;$R$10:$R$15;0)))
 

relaxim

Altın Üye
Altın Üye
Katılım
30 Ağustos 2009
Mesajlar
119
Beğeniler
6
Excel Vers. ve Dili
ofis 2010
#7
Alternatif olarak.
Kod:
=EĞER(SOLDAN(YERİNEKOY(B$3;"x";"X");BUL("X";YERİNEKOY($B3;"x";"X"))-1)*1<=12;İNDİS($O$3:$O$8;KAÇINCI($C3;$R$3:$R$8;0))*$C3;İNDİS($O$10:$O$15;KAÇINCI($C3;$R$10:$R$15;0))*$C3)
Sn Çıtır Fomül hata verdi düzelt deyince yok hatası verdi. Sanırım daha önce dizi formülü olduğu için olabilir mi ? Daha sonra tekrar deneyeceğim. Teşekkürler...
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
3,174
Beğeniler
272
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#11
Çıtır bey sonuç doğru. Ben daha önce Ali beyin dizi formülü üzerine yapıştırdığım için sıkıntı oldu sanırım. Teşekkürler...
Gönderdiğim formülde İlk baştaki B3 hatalı olarak sabitlenmiş sanırım ondan olmuştur.Düzeltildi.Dönüş yaptığınız için teşekkür ederim.
 
Üst