takvim haftanın gün sayısı toplama

KMLZDMR

Altın Üye
Altın Üye
Katılım
9 Nisan 2015
Mesajlar
476
Beğeniler
3
Excel Vers. ve Dili
2003 TÜRKÇE EXCEL
#1
Merhaba,
ekli dosyada takvimde haftanın gün sayısını kriterlere göre toplama için formüle ihtiyaç (formül AC11 hücresine uygulanıp aşağıya ve sağa uygulanabilecek tek formül)var. Lütfen yardımcı olur musunuz?

AC11 hücresine uygulanacak ve sağa aşağı çekilecek tek bir formül ile AC9 AD9 AE9
17, 25 ,33 satırlarında yazılı ay adlarını 1.kriter alarak takvim=$C$9:$Z$40 alanındaki ay adlarını esas alarak;
10,18,26,34. satırlardaki gün adları dolu olan sarı alandaki takvim günlerinin hafta sayısına tekabül eden GÜN SAYISINI bulmak için gerekli formül nasıl yapılır
 

Ekli dosyalar

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,616
Beğeniler
729
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#2
Deneyiniz.AC 11 kopyalayınız.Aşağı ve sağa çoğaltınız.
Kod:
=BAĞ_DEĞ_SAY(DOLAYLI(ADRES(SATIR();SÜTUN(A1)*7-6+SÜTUN(A1)+2)&":"&ADRES(SATIR();SÜTUN(A1)*7-6+SÜTUN(A1)+8)))
veya
Kod:
=BAĞ_DEĞ_SAY(KAYDIR(DOLAYLI(ADRES(SATIR();SÜTUN(A$1)*8-4));;;;7))
 
Son düzenleme:

KMLZDMR

Altın Üye
Altın Üye
Katılım
9 Nisan 2015
Mesajlar
476
Beğeniler
3
Excel Vers. ve Dili
2003 TÜRKÇE EXCEL
#3
Sayın çıtır teşekkür ederim.
formül hesapladı...Ancak uygulama yapacağım alan büyük olup formülde Satır(), Sütun() gibi değişkenlik oluşturacak işlemler olmadan
konuyu "Topla.Çarpım" yada daha başka tür formülle yapabilmek mümkünse buna ilişkin formül yapılabilir mi?
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,616
Beğeniler
729
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#4
Sayın çıtır teşekkür ederim.
formül hesapladı...Ancak uygulama yapacağım alan büyük olup formülde Satır(), Sütun() gibi değişkenlik oluşturacak işlemler olmadan
konuyu "Topla.Çarpım" yada daha başka tür formülle yapabilmek mümkünse buna ilişkin formül yapılabilir mi?
Rica ederim.Dönüş yaptığınız için teşekkür ederim.
 
Katılım
8 Mart 2011
Mesajlar
13,048
Beğeniler
747
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#5
Merhaba.
Aşağıda üç adet alternatif formül verdim.
İlk hücreye uygulayıp sağa ve aşağı doğru kopyalayabilirsiniz.
Ayrıca formülün sadeleşmesi bakımından, SÜTUNSAY($AC9:AC9) yerine SÜTUN($A1) de yazabilirsiniz.
=EĞERSAY(KAYDIR($B11;0;8*(SÜTUNSAY($AC9:AC9)-1)+2;1;7);">0")
=TOPLA.ÇARPIM(--(KAYDIR($B11;0;8*(SÜTUNSAY($AC9:AC9)-1)+2;1;7)>0))
=TOPLA.ÇARPIM(1*(KAYDIR($B11;0;8*(SÜTUNSAY($AC9:AC9)-1)+2;1;7)>0))
 

KMLZDMR

Altın Üye
Altın Üye
Katılım
9 Nisan 2015
Mesajlar
476
Beğeniler
3
Excel Vers. ve Dili
2003 TÜRKÇE EXCEL
#6
Ömer BARAN üstadım çok teşekkür ederim.
3 formülde öğretici oldu. Sayın #Çıtır ile 5 oldu.
ANCAK Ayrıca formülün sadeleşmesi bakımından, SÜTUNSAY($AC9:AC9) yerine SÜTUN($A1) de yazabilmeyi yapamadım.
=EĞERSAY(KAYDIR($B11;0;8*(SÜTUN($A1)-1)+2;1;7);">0") <bu formül sağa doğru aynı değeri getirdi...
=TOPLA.ÇARPIM(--(KAYDIR($B11;0;8*(SÜTUN($A1)-1)+2;1;7)>0)) değer hatası verdi...
=TOPLA.ÇARPIM(1*(KAYDIR($B11;0;8*(SÜTUN($A1)-1)+2;1;7)>0))
değer hatası verdi...
uygulamada nerede hata yapıyorum? Doğrusu nasıl yapılır. Lütfen belirtir misiniz?
 

İdris SERDAR

Moderatör
Yönetici
Katılım
21 Ekim 2005
Mesajlar
15,597
Beğeniler
236
Excel Vers. ve Dili
Excel, 2016 - İngilizce
#9
.

Bana göre, önce takvimin oluşturulması, daha sonra basit formülle hafta gün sayılarının elde edilmesi daha kolay olur.

Ayrıca dikkat edilirse ay başlarındaki hafta ile ay sonlarındaki hafta günleri farklı diğer günler ise sabit 7 gündür. Buna göre de formüller düzenlenebilir.

Benim basit olarak (Takvim basit değil) yaptığım dosyayı burada görebilirsiniz.

http://www.excelgurusu.com/aylik-yillik-takvim/


.
 
Son düzenleme:
Katılım
8 Mart 2011
Mesajlar
13,048
Beğeniler
747
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#10
Zaten Sayın @KMLZDMR 'in belgesindeki şey esas olarak takvim değil.
YIL yok, veriler 1, 2, 3 gibi sayı, ortada bir TARİH verisi de yok.

Bu nedenle de verilen formüller TARİH, HAFTASAY, HAFTANINGÜNÜ gibi işlevler yerine
alandaki dolu hücre sayısını tespit etmeye yönelik formüller.
.
 

İdris SERDAR

Moderatör
Yönetici
Katılım
21 Ekim 2005
Mesajlar
15,597
Beğeniler
236
Excel Vers. ve Dili
Excel, 2016 - İngilizce
#11
Zaten Sayın @KMLZDMR 'in belgesindeki şey esas olarak takvim değil.
YIL yok, veriler 1, 2, 3 gibi sayı, ortada bir TARİH verisi de yok.

Bu nedenle de verilen formüller TARİH, HAFTASAY, HAFTANINGÜNÜ gibi işlevler yerine
alandaki dolu hücre sayısını tespit etmeye yönelik formüller.
.

Ömer bey, merhaba.

Verilen şekil neyin nesi? Dosyanın adı ve konu başlığı da takvim haftanın gün sayısı toplama şeklinde.

Arkadaşımızın oluşturduğu aslında takvim. Ancak, o bölümlerini (formüllerini vs.) paylaşmadığını zannediyorum.

Ayrıca dikkat ederseniz ben de TARİH, HAFTASAY, HAFTANINGÜNÜ gibi formüller takvim dışında kullanmadım.

.
 
Son düzenleme:
Katılım
8 Mart 2011
Mesajlar
13,048
Beğeniler
747
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#12
Üçer aylık gruplar halinde oluşturulmuş bir yapı olduğundan;
konu sahibi Sn, @KMLZDMR'in, GEÇİCİ VERGİ konusunda bir çalışmayı tamamlamaya çalıştığını sanıyorum (kendisi muhasebe konularıyla meşgul).
Tabi benimkisi bir tahminden ibaret ve verilmiş herhangi bir detay da yok.

Destek vermeye hazır birçok üye varken hala örnek belge hazırlama konusundaki uyarılarımız konusunda pek ilerleme kaydedemiyoruz.
Bunun için cevaplarımın altındaki İMZA bölümünde açıklama yazmaktan veya rastladığımızda uyarmaktan başka bir şey de yapamıyoruz.
.
 

PriveT

Altın Üye
Katılım
8 Ekim 2009
Mesajlar
579
Beğeniler
131
Excel Vers. ve Dili
Office 2010 & 2016 TR
#13
.

Bana göre, önce takvimin oluşturulması, daha sonra basit formülle hafta gün sayılarının elde edilmesi daha kolay olur.

Ayrıca dikkat edilirse ay başlarındaki hafta ile ay sonlarındaki hafta günleri farklı diğer günler ise sabit 7 gündür. Buna göre de formüller düzenlenebilir.

Benim basit olarak (Takvim basit değil) yaptığım dosyayı burada görebilirsiniz.

http://www.excelgurusu.com/aylik-yillik-takvim/


.
Takviminiz harika olmuş, emeğinize sağlık.
 

KMLZDMR

Altın Üye
Altın Üye
Katılım
9 Nisan 2015
Mesajlar
476
Beğeniler
3
Excel Vers. ve Dili
2003 TÜRKÇE EXCEL
#14
Sayın Serdar ve Ömer Baran Bey,
iletinizi yeni gördüm.
Sorumdaki Takvimi internetten indirdim. (hafta sayılarını göstermesi benim için gerekliydi)
Yan tarafa üç aylık yapmamın nedeni takvim de 3 aylık sütun yapması...
Haftanın gün sayısının kullanım yeri ise bir nevi Puantaj sistemi...
Sayın serdar sizin çalışma çok yararlı olmuş teşekkür ederim.
 
Üst