Soru Tekrarlayan Hücre Sayıları Hk.

Katılım
12 Şubat 2019
Mesajlar
21
Beğeniler
1
Excel Vers. ve Dili
Vera. 10 Dil Türkçe
#1
Merhaba,
bir sütunda sadece 0 lar ve 1 lerle oluşan hücrelerin tekrar sayılarını getirebileceğim bir formül far mıdır acaba?misal sütun şu şekilde olsun:

sıra no - sayılar - tekrar sayısı
1 0 null(veya boş hücre de olabilir)
2 0 null(veya boş hücre de olabilir)
3 0 null(veya boş hücre de olabilir)
4 1 3 (kendisine kadar yukarıda sıfır sayısı 3 kez tekrarlandı)
5 0 null(veya boş hücre de olabilir)
6 0 null(veya boş hücre de olabilir)
7 0 null(veya boş hücre de olabilir)
8 0 null(veya boş hücre de olabilir)
9 0 null(veya boş hücre de olabilir)
10 0 null(veya boş hücre de olabilir)
11 1 6 (kendisinden önceki bir sayısından sonra 6 tane sıfır sayısı tekrarlandı)
12 1 0 (tekrarlanan sıfır sayısı olmadığı için)
13 0 null(veya boş hücre de olabilir)
14 1 1
15 1 0 0 (tekrarlanan sıfır sayısı olmadığı için)

yukarıdaki örnek verdiğim tabloda tekrar sayısı sütunun bir formülle yazabilir miyiz?
şimdiden teşekkür ederim.
 

ÖmerBey

Destek Ekibi
Destek Ekibi
Katılım
22 Ekim 2012
Mesajlar
2,645
Beğeniler
189
Excel Vers. ve Dili
2007 Türkçe
#3
Merhaba,
C2 hücresine aşağıdaki formülü kopyalayıp aşağı çekerek çoğaltınız. (0 ve 1'lerin B sütununda olduğu varsayıldı)
Kod:
=EĞER(B2=1;EĞERSAY(B$1:B2;0)-TOPLA(C$1:C1);"Null")
 
Katılım
12 Şubat 2019
Mesajlar
21
Beğeniler
1
Excel Vers. ve Dili
Vera. 10 Dil Türkçe
#4
Merhaba Ömer Bey,
Yardımlarınız için çok teşekkür ederim.
 
Üst