• FORUMU MOBİL UYGULAMADAN TAKİP EDİN

    Forumu isteyen üyelerimiz Tapatalk (Harici bir hizmet) üzerinden mobil uygulamadan takip edebilirler.
    iOS için : https://itunes.apple.com/app/id307880732?mt=8
    Android için : https://play.google.com/store/apps/details?id=com.quoord.tapatalkpro.activity
    adreslerinden indirebilirsiniz.

    Bir iki haftaya da foruma özel kendi uygulamamız yayında olacak.
ALTIN ÜYELİK Hakkında Bilgi
-----------------------

TÜM FORMÜLLERİ VE MAKROYA ÇEVİRME

yanginci34

Altın Üye
Altın Üye
Katılım
6 Temmuz 2010
Mesajlar
834
Beğeniler
18
Excel Vers. ve Dili
excel2013
#1
Merhaba arkadaşlar bizim puantaj şekli değişti ve her ay bu puantajı elle hem formüllerinde hemde tablo şeklinde değişiklikler yapıyorum daha basit nasıl olabilir. İlgilenen arkadaşlara şimdiden teşekkür ederim.
 

Ekli dosyalar

Katılım
8 Mart 2011
Mesajlar
11,567
Beğeniler
214
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#3
Merhaba.

Belgeyi ve işleyişi tasarlama işi size ait.
Tasarım ve işleyişi planladığınızda, şurası şöyle olunca şunun/şunların olmasını istiyorum (net hücre adresi vs belirterek) gibi net soru sorarsanız kısa sürede sonuca ulaşırsınız.
Fark ettiğim bir hususu belirteyim. AH1:AK1 aralığındaki hesaplamaya gerek yok, o hücreleri silin ve
AI2 hücresindeki formülü aşağıdakiyle değiştirip sağa doğru kopyalayın.
.
=EĞER(AH2="";"";EĞER(AY(AH2)<>AY(AH2+1);"";AH2+1))
 

yanginci34

Altın Üye
Altın Üye
Katılım
6 Temmuz 2010
Mesajlar
834
Beğeniler
18
Excel Vers. ve Dili
excel2013
#4
Merhaba; Öncelikle Ömer Bey'e ilgisinden dolayı teşekkür ederim. Ömer Bey, sizin öneriniz doğrultusunda isteklerimi dosya içinde belirtmeye çalıştım.
İlgilenen arkadaşlara şimdiden teşekkürler.
 

Ekli dosyalar

KMLZDMR

Altın Üye
Altın Üye
Katılım
9 Nisan 2015
Mesajlar
415
Beğeniler
3
Excel Vers. ve Dili
2003 TÜRKÇE EXCEL
#6
Sayın Ömer BARAN üstadım güzel bir çalışma olmuş.
 

yanginci34

Altın Üye
Altın Üye
Katılım
6 Temmuz 2010
Mesajlar
834
Beğeniler
18
Excel Vers. ve Dili
excel2013
#7
Merhaba ; Hocam öncelikle ilginize çok teşekkür ederim. Aşağıda sütun olarak görmek istediklerimi açıklamaya çalışacağım.
AQ Sütununda hafta sonu günlerinde, normal çalışma (X) işareti konulursa 7,5 saat ve yarım gün çalışma (/) işareti konulursa 4 saat artarak göstermesi.
AS Sütununda bayram günlerinde, normal çalışma (X) işareti konulursa 7,5 saat ve yarım gün çalışma (/) işareti konulursa 4 saat artarak göstermesi.
Umarım açıklaya bilmişimdir.
 
Son düzenleme:

yanginci34

Altın Üye
Altın Üye
Katılım
6 Temmuz 2010
Mesajlar
834
Beğeniler
18
Excel Vers. ve Dili
excel2013
#8
Sayın Ömer Hocam; Ekteki dosyada bazı değişiklikler yaptım. Dolayısı ile isteklerimde değişti.
Şöyle;
AQ Sütununda hafta sonu günlerinde, normal çalışma (X) işareti konulursa 7,5 saat ve yarım gün çalışma (/) işareti konulursa 4 saat artarak göstermesi.
AS Sütununda bayram günlerinde, normal çalışma (X) işareti konulursa 7,5 saat ve Arife gününde normal çalışma (X) işareti konulursa 4 saat artarak göstermesi.
Umarım açıklaya bilmişimdir.
 

Ekli dosyalar

yanginci34

Altın Üye
Altın Üye
Katılım
6 Temmuz 2010
Mesajlar
834
Beğeniler
18
Excel Vers. ve Dili
excel2013
#10
Hocam süpersiniz elinize sağlık şimdi dediğiniz gibi haftasonu rt veya A yani arifeye gelirse rt veya arife geçerlidir.
 
Katılım
8 Mart 2011
Mesajlar
11,567
Beğeniler
214
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#11
Son eklediğim belgedeki formül buna göre oluşturulmuştu.
Sorun çözüldü diyebilir miyiz o zaman?
 

yanginci34

Altın Üye
Altın Üye
Katılım
6 Temmuz 2010
Mesajlar
834
Beğeniler
18
Excel Vers. ve Dili
excel2013
#12
Hocam 28 ekimde X koyarsam hafta sonu çalışmaya da ekleme yapıyor yapmaması gerekli.
 
Katılım
8 Mart 2011
Mesajlar
11,567
Beğeniler
214
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#13
AQ3'deki dizi formülüne, kırmızı renklendirdiğim kısmı ekleyip, tekrar dizi formülü olarak uygulayın (CTRL+SHIFT+ENTER).
=TOPLA.ÇARPIM(($G$2:$AK$2<>"")*(--EĞER($G$2:$AK$2="";0;(EĞERSAY(bayram;$G$2:$AK$2)=0)*(EĞERSAY(arife;$G$2:$AK$2)=0)*HAFTANINGÜNÜ($G$2:$AK$2;2)=7))*(($G3:$AK3="X")*7,5+($G3:$AK3="/")*4))
 
Katılım
8 Mart 2011
Mesajlar
11,567
Beğeniler
214
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#15
Madem belgedeki formülleri yok etmeye çalışıyorsunuz.
AQ ve AS sütunuyla sınırlı olarak ekteki belgeye yaptığım ilaveyi deneyiniz.
 

Ekli dosyalar

Katılım
8 Mart 2011
Mesajlar
11,567
Beğeniler
214
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#17
Diğer formülleriniz/hesaplamalarınız sorunsuz ise tüm formüller kaldırılıp sonuçların hücrelere yazılması sağlanabilir..
 

yanginci34

Altın Üye
Altın Üye
Katılım
6 Temmuz 2010
Mesajlar
834
Beğeniler
18
Excel Vers. ve Dili
excel2013
#18
Diğer formülleriniz/hesaplamalarınız sorunsuz ise tüm formüller kaldırılıp sonuçların hücrelere yazılması sağlanabilir..
Size zahmet olmazsa benim için daha güzel olur Hocam


GM 8 d cihazımdan Tapatalk kullanılarak gönderildi
 
Üst