• FORUMU MOBİL UYGULAMADAN TAKİP EDİN

    Forumu isteyen üyelerimiz Tapatalk (Harici bir hizmet) üzerinden mobil uygulamadan takip edebilirler.
    iOS için : https://itunes.apple.com/app/id307880732?mt=8
    Android için : https://play.google.com/store/apps/details?id=com.quoord.tapatalkpro.activity
    adreslerinden indirebilirsiniz.

    Bir iki haftaya da foruma özel kendi uygulamamız yayında olacak.
ALTIN ÜYELİK Hakkında Bilgi
-----------------------

Ünvana göre sıra numarası verme ve otomatik sıralama

teyadih

Altın Üye
Altın Üye
Katılım
15 Ekim 2014
Mesajlar
441
Beğeniler
6
Excel Vers. ve Dili
Excell 2010 Türkçe
#1
Kolay gelsin arkadaşlar
H sütununda bulunan metinlerin içinde eğer 4 varsa 1001 den, metinlerin içinde 4 yoksa 1 den başlayarak A sütunundaki örnekte olduğu üzere sıra no vererek otomatik olarak sıralatabilir miyiz?
Yardımcı olur musunuz?
Örnek dosyayı gönderiyorum işleyip gönderirseniz memnun olurum.
Eğer otomatik sıralatma olmuyorsa sıra no için formülde olabilir.
Teşekkür ederim.
 

Ekli dosyalar

Ömer

Moderatör
Yönetici
Katılım
18 Ağustos 2007
Mesajlar
19,251
Beğeniler
34
Excel Vers. ve Dili
2010-Türkçe
#3
Merhaba,

Alternatif.

A4: Dizi formülüdür.
Kod:
=EĞER(H4="";"";MAK(EĞER(EHATALIYSA(BUL("4";H4));EĞER($A$3:A3<1001;$A$3:A3);EĞER($A$3:A3>1000;$A$3:A3;1000)))+1)
 

teyadih

Altın Üye
Altın Üye
Katılım
15 Ekim 2014
Mesajlar
441
Beğeniler
6
Excel Vers. ve Dili
Excell 2010 Türkçe
#4
Teşekkürler sayın muygun ve ömer elinize sağlık en kısa zamanda inceleyip dönüş yapacağım
 

teyadih

Altın Üye
Altın Üye
Katılım
15 Ekim 2014
Mesajlar
441
Beğeniler
6
Excel Vers. ve Dili
Excell 2010 Türkçe
#5
Sayın muygun sizen örnek çalışıyor Ancak ben kendi sayfamı uyguladığımda sıra noyu unvana göre vermiyor ve sıra noyu da 2 den başlatıyor.
B ile H (dahil) arasındaki bilgileri formül ile başka yerden çekiyorum ve sanırım formül olduğu için H sütununda 4 yazıp yazmasını dikkate almıyor.
Formülleri değer olarak değilde formül olarak görecek şekilde güncelleyebilir misiniz size zahmet
 

teyadih

Altın Üye
Altın Üye
Katılım
15 Ekim 2014
Mesajlar
441
Beğeniler
6
Excel Vers. ve Dili
Excell 2010 Türkçe
#6
Sayın ömer sizin formül tamam ancak H sütünü boş olanları da 1 den itibaren verdiği sıra nodan vermeye devam ediyor.
 

Ömer

Moderatör
Yönetici
Katılım
18 Ağustos 2007
Mesajlar
19,251
Beğeniler
34
Excel Vers. ve Dili
2010-Türkçe
#7
Tam anlayamadım.
Hatayı örnek dosya ekleyerek gösterir misiniz.
 

teyadih

Altın Üye
Altın Üye
Katılım
15 Ekim 2014
Mesajlar
441
Beğeniler
6
Excel Vers. ve Dili
Excell 2010 Türkçe
#8
Bilgileri formülle aldığım için örnek dosyayı ekleyemiyorum sayın ömer. Sanırım kullandığım dosyadaki bilgileri formülle aldığım için H sütunu boş olsa da sıra no veriyor. Formül değil de değerlere göre vermesi gerekiyor anladığım kadarıyla
 

muygun

Özel Üye
Katılım
6 Temmuz 2004
Mesajlar
7,358
Beğeniler
63
Excel Vers. ve Dili
Excel-2003 Türkçe
#9
Formülleriniz 1 karakterlik veri getiriyor. Bunu boş karaktere eşitlerseniz sanırım sorun kalmaz.
 

teyadih

Altın Üye
Altın Üye
Katılım
15 Ekim 2014
Mesajlar
441
Beğeniler
6
Excel Vers. ve Dili
Excell 2010 Türkçe
#10
Kusura bakmayın sayın muygun 1 karakterlik veri getirme ve boş karaktere eşitleme konusunu anlayamadım. Boş karaktere nasıl eşitliyoruz acaba. Bilgileri getirmek için kullandığım formül =EĞERHATA(DÜŞEYARA(B4;'[1.HAKİM VE PERSONEL LİSTESİ.xlsm]GENEL'!$P:$AQ;6;0);0)
 

muygun

Özel Üye
Katılım
6 Temmuz 2004
Mesajlar
7,358
Beğeniler
63
Excel Vers. ve Dili
Excel-2003 Türkçe
#11
Dosyanızda N17 hücresine;
=UZUNLUK(H17)
yazın.
 

muygun

Özel Üye
Katılım
6 Temmuz 2004
Mesajlar
7,358
Beğeniler
63
Excel Vers. ve Dili
Excel-2003 Türkçe
#12
Formülünüz 0 getiriyor.
Yani boş gördüğünüz hücrede sıfır var.
Yada H17 hücresini kopyalayıp bir başka hücreye Özel yapıştır>değerler şeklinde yapıştırın.
Yine sıfırı göreceksiniz.
Formülünüzü;
=eğer (formülünüz)=0;"";formülünüz
şeklinde alırsanız sıfır yerine boş değere eşitlemiş olursunuz.
 

teyadih

Altın Üye
Altın Üye
Katılım
15 Ekim 2014
Mesajlar
441
Beğeniler
6
Excel Vers. ve Dili
Excell 2010 Türkçe
#13
Sayın muygun sizi yoruyorum kusura bakmayın. Yanlış anlamadıysam
=eğer (DÜŞEYARA(B4;'[1.HAKİM VE PERSONEL LİSTESİ.xlsm]GENEL'!$P10:$AQ1006;6;0))=0;"";DÜŞEYARA(B4;'[1.HAKİM VE PERSONEL LİSTESİ.xlsm]GENEL'!$P10:$AQ1006;6;0) şeklinde uyguladım ancak yine aynı oldu malesef
 

Ömer

Moderatör
Yönetici
Katılım
18 Ağustos 2007
Mesajlar
19,251
Beğeniler
34
Excel Vers. ve Dili
2010-Türkçe
#15
Formülde;

=EĞER(H4="" başlayan bölümü;

=EĞER(H4=0 değiştirip deneyin.

Dizi formülüne çevirmeyi atlamayın.
 

teyadih

Altın Üye
Altın Üye
Katılım
15 Ekim 2014
Mesajlar
441
Beğeniler
6
Excel Vers. ve Dili
Excell 2010 Türkçe
#17
Çok teşekkür ederim sayın muygun ve sayın ömer elinize sağlık.
 

teyadih

Altın Üye
Altın Üye
Katılım
15 Ekim 2014
Mesajlar
441
Beğeniler
6
Excel Vers. ve Dili
Excell 2010 Türkçe
#18
Sayın muygun gönderdiğiniz son haline sadece A sütununa göre sıralamayı koyar mısınız? size zahmet
 
Üst