Soru Bir önceki ayın son 15 günü ile içerisinde bulunulan ayın ilk 14 gününü tanımlama?

s.savas

Altın Üye
Katılım
11 Ocak 2009
Mesajlar
678
Beğeniler
4
Excel Vers. ve Dili
2003
#1
Merhaba arkadaşlar.
Şu formülle normalde ayın 1.günü ile son günü arasındaki günleri istenilen aralığa yazdırabiliyoruz.
Kod:
=EĞER(AY($AJ$1+SÜTUN()-4)=AY($AJ$1);$AJ$1+SÜTUN()-4;"")
Ancak işçi puantajlarında bir önceki ayın son 15 günü ile içerisinde bulunulan ayın ilk 14 gününe ait veriler esas alınıyor.
Buna yönelik bir çalışma içerisindeyim. Yukarıdaki formülü bu amaca göre yeniden revize etmem gerekiyor.
AJ1 hücresi: de Ocak ayı 01.01.2019 şeklinde tanımlanmış
AJ2 hücresi: de Şubat ayı 01.02.2019 şeklinde tanımlanmıştır.
D4:R4 aralığına Ocak ayının son 15 günü
S4:AH4 aralığına ise Şubat ayının ilk 14 gününü verecek şekilde tanımlama gerekiyor.
Gerekli açıklama ve dosya ekte sunulmuştur. Zamanı müsait olan arkadaşların ilgisini rica ediyorum.

http://dosya.co/t8bzcd201b8b/Kitap2.xls.html
 
Katılım
8 Mart 2011
Mesajlar
12,387
Beğeniler
475
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#2
Merhaba.
D4 hücresine uygulayıp sağa doğru kopyalayın.
Formülün çalışması için AJ2 hücresine lüzum yok, hesaplama AJ1'deki tarih üzerinden yapılıyor.
=EĞER(SÜTUN()-18>14;"";SERİAY($AJ$1;0)-18+SÜTUN())
 

s.savas

Altın Üye
Katılım
11 Ocak 2009
Mesajlar
678
Beğeniler
4
Excel Vers. ve Dili
2003
#3
Ömer hocam hızlı cevap için teşekkürler.
Kod:
=EĞER(SÜTUN()-18>14;"";SERİAY($AJ$1;0)-18+SÜTUN())
Bu formülle Ocak ayı 17 sinden itibaren başladı.
Kod:
=EĞER(SÜTUN()-20>14;"";SERİAY($AJ$1;0)-20+SÜTUN())
olarak değiştirince Ocak ayı 15'nden itibaren başladı ancak devamında şubat 12 den başladı.
 

PriveT

Altın Üye
Katılım
8 Ekim 2009
Mesajlar
169
Beğeniler
17
Excel Vers. ve Dili
Office 2010 & 2016
#4
Ömer hocam hızlı cevap için teşekkürler.
Kod:
=EĞER(SÜTUN()-18>14;"";SERİAY($AJ$1;0)-18+SÜTUN())
Bu formülle Ocak ayı 17 sinden itibaren başladı.
Kod:
=EĞER(SÜTUN()-20>14;"";SERİAY($AJ$1;0)-20+SÜTUN())
olarak değiştirince Ocak ayı 15'nden itibaren başladı ancak devamında şubat 12 den başladı.
Sayın @s.savas sizin ilk sorudaki isteğinize göre 17 Ocak; Ocak ayının son 15'inci günü oluyor. Siz son 15 gün değil de ay kaç çekerse çeksin ayın 15'inden başlamasını mı istiyorsunuz?
 

s.savas

Altın Üye
Katılım
11 Ocak 2009
Mesajlar
678
Beğeniler
4
Excel Vers. ve Dili
2003
#5
Evet, bir önceki ayın 15. gününden itibaren içerisinde bulunulan ayın 14.gününe kadar ki günleri tanımlamalı.

SM-N910C cihazımdan Tapatalk kullanılarak gönderildi
 

PriveT

Altın Üye
Katılım
8 Ekim 2009
Mesajlar
169
Beğeniler
17
Excel Vers. ve Dili
Office 2010 & 2016
#7
Son düzenleme:

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
3,337
Beğeniler
320
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#8
Ömer BARAN üstadımın müsaadesi ile aşağıdaki formülü deneyiniz.Başlangıç tarihini AJ1,Bitiş tarihi AJ2 yazınız.
D4 kopyalayınız.Sağa doğru çoğaltınız.
Kod:
=EĞERHATA(EĞER(SÜTUN()=4;$AJ$1;EĞER($AJ$1+SÜTUN(A1)-1>$AJ$2;"";$AJ$1+SÜTUN(A1))-1);"")
 

s.savas

Altın Üye
Katılım
11 Ocak 2009
Mesajlar
678
Beğeniler
4
Excel Vers. ve Dili
2003
#9
Soru sormak zor zanaat vesselam.
Çok yerinde bir tesbit.
Düz mantıkla bakınca her ayın standart 30 gün çektiği şekilleniyor insanın zihninde.
Ancak iş hesap kitap işine gelince her ayın 30 gün olmadığı kabak gibi ortaya çıkıyor.
Şubatta veya 31 gün olan aylarda nasıl bir işlem yapılması sorunu ortaya çıkıyor.
Naçizane bizde düştük bu hataya.



SM-N910C cihazımdan Tapatalk kullanılarak gönderildi
 

s.savas

Altın Üye
Katılım
11 Ocak 2009
Mesajlar
678
Beğeniler
4
Excel Vers. ve Dili
2003
#10
Ömer BARAN üstadımın müsaadesi ile aşağıdaki formülü deneyiniz.Başlangıç tarihini AJ1,Bitiş tarihi AJ2 yazınız.
D4 kopyalayınız.Sağa doğru çoğaltınız.
Kod:
=EĞERHATA(EĞER(SÜTUN()=4;$AJ$1;EĞER($AJ$1+SÜTUN(A1)-1>$AJ$2;"";$AJ$1+SÜTUN(A1))-1);"")
Arkadaşlar teşekkür ediyorum ilginize.
Dişçi koltuğundan kalktıktan sonra netice hakkında bilgi verebilirim.


SM-N910C cihazımdan Tapatalk kullanılarak gönderildi
 
Katılım
8 Mart 2011
Mesajlar
12,387
Beğeniler
475
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#11
Mesele sorunun soruluş biçiminde aslında ve belge nin sayfa yapısında (2'nci satırdaki hücre birleştirmesi ve içerikleri).
Herneyse; aşağıdaki formülü kullanabilirsiniz.
Hesaplama yine AJ1 hücresindeki ilk tarihe göre yapılıyor.
=EĞER($AJ$1+13+SÜTUN(A$1)>SERİAY($AJ$1;0)+14;"";$AJ$1+13+SÜTUN(A$1))
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
3,337
Beğeniler
320
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#12
Arkadaşlar teşekkür ediyorum ilginize.
Dişçi koltuğundan kalktıktan sonra netice hakkında bilgi verebilirim.


SM-N910C cihazımdan Tapatalk kullanılarak gönderildi
Geçmiş olsun.Excel Vers. ve Dili2003 bu şekilde ise aşağıdaki formülü deneyiniz.Dönüş yaptığınız için teşekkür ederim.
Kod:
=EĞER(EHATALIYSA(EĞER(SÜTUN()=4;$AJ$1;EĞER($AJ$1+SÜTUN(A1)-1>$AJ$2;"";$AJ$1+SÜTUN(A1))-1));"";EĞER(SÜTUN()=4;$AJ$1;EĞER($AJ$1+SÜTUN(A1)-1>$AJ$2;"";$AJ$1+SÜTUN(A1))-1))
 
Katılım
8 Mart 2011
Mesajlar
12,387
Beğeniler
475
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#13
Tekrar merhaba.

#11 numaralı cevapta yeni formül vermiştim >> =EĞER($AJ$1+13+SÜTUN(A$1)>SERİAY($AJ$1;0)+14;"";$AJ$1+13+SÜTUN(A$1))

Yeni duruma göre hücre renkendirmelerini koşullu biçimlendirme ile yapmanızı önermeliyim.
Ayrıca; fark ettiğim bir hususu daha belirteyim; belgedeki 5'inci satırdaki formül de gereksiz.
D5 hücresine =D4 formülünün uygulanıp, sağa doğru kopyalanması yeterli olur.
.
 

s.savas

Altın Üye
Katılım
11 Ocak 2009
Mesajlar
678
Beğeniler
4
Excel Vers. ve Dili
2003
#14
Mesele sorunun soruluş biçiminde aslında ve belge nin sayfa yapısında (2'nci satırdaki hücre birleştirmesi ve içerikleri).
Herneyse; aşağıdaki formülü kullanabilirsiniz.
Hesaplama yine AJ1 hücresindeki ilk tarihe göre yapılıyor.
Tekrar merhaba.

#11 numaralı cevapta yeni formül vermiştim >> =EĞER($AJ$1+13+SÜTUN(A$1)>SERİAY($AJ$1;0)+14;"";$AJ$1+13+SÜTUN(A$1))

Yeni duruma göre hücre renkendirmelerini koşullu biçimlendirme ile yapmanızı önermeliyim.
Ayrıca; fark ettiğim bir hususu daha belirteyim; belgedeki 5'inci satırdaki formül de gereksiz.
D5 hücresine =D4 formülünün uygulanıp, sağa doğru kopyalanması yeterli olur.
.
Geçmiş olsun.Excel Vers. ve Dili2003 bu şekilde ise aşağıdaki formülü deneyiniz.Dönüş yaptığınız için teşekkür ederim.
Kod:
=EĞER(EHATALIYSA(EĞER(SÜTUN()=4;$AJ$1;EĞER($AJ$1+SÜTUN(A1)-1>$AJ$2;"";$AJ$1+SÜTUN(A1))-1));"";EĞER(SÜTUN()=4;$AJ$1;EĞER($AJ$1+SÜTUN(A1)-1>$AJ$2;"";$AJ$1+SÜTUN(A1))-1))
Arkadaşlar ayrı ayrı teşekkür ediyorum. Formül çalışıyor.
 
Üst