Bir veriyi görene kadar diğer verileri alma

Katılım
14 Ocak 2021
Mesajlar
2
Excel Vers. ve Dili
türkçe
Merhaba, benim yapmak istediğim örneğin bir hücrede 2 değeri var benim yazdığım formülle 2 değerini görene kadar başka hücrelerdeki verileri toplamak istiyorum nasıl yaparım.
 

NextLevel

Altın Üye
Katılım
22 Ekim 2017
Mesajlar
682
Excel Vers. ve Dili
Ofis 2016 TR
2 yi geçme duru mu olursa ne yapacak? Mesela ilk 5 değer toplamı 1,9 du. bir sonraki değer 0,2 ise sonuç toplamı ne olacak?
Toplama yapılınca sonuçta ne olacak?
Toplamı bir hücreye mi yazacağız sadece?
Toplanılan veri adedini mi yazacağız bir yere?
Toplanılan hücre aralığını mı yazacağız?
vs vs
 
Katılım
14 Ocak 2021
Mesajlar
2
Excel Vers. ve Dili
türkçe
mesela bir örnek üzerinden anlatayım

Ankara 7.......8.......5.......2.......3.......5.......6.......2
İstanbul x..............y............................z...................

İstanbul satırındaki X değeri Ankara satırındaki rakamları 2 ye kadar olan kısmına kadar toplayacak. Yani toplama işlemi başlayacak 2 değerine gelince bitecek.

X=7+8+5

Y=5

Z=5+6

bunun için nasıl bir formül yazabilirim ?
 

NextLevel

Altın Üye
Katılım
22 Ekim 2017
Mesajlar
682
Excel Vers. ve Dili
Ofis 2016 TR
Ankara A1 de..sayılar B1 den itibaren sağa doğru Z1 e kadar gittiğini kabul ettim. Değilse uyarlamlaısınız.
Üç formül de dizi formülü olup hücre içine yapıştırdıktan sonra, mouse formül içindeyen Ctrl+Shift+Enter tuş kombinasyonuna basın.
X için
=TOPLA(KAYDIR(B1;0;0;1;BÜYÜK(EĞER(B1:Z1=2;1;0)*SÜTUN(B1:Z1);3)-2))

Y için
=TOPLA(KAYDIR(B1;0;BÜYÜK(EĞER(B1:Z1=2;1;0)*SÜTUN(B1:Z1);3)-1;1;BÜYÜK(EĞER(B1:Z1=2;1;0)*SÜTUN(B1:Z1);2)-BÜYÜK(EĞER(B1:Z1=2;1;0)*SÜTUN(B1:Z1);3)-1))

Z için
=TOPLA(KAYDIR(B1;0;BÜYÜK(EĞER(B1:Z1=2;1;0)*SÜTUN(B1:Z1);2)-1;1;BÜYÜK(EĞER(B1:Z1=2;1;0)*SÜTUN(B1:Z1);1)-BÜYÜK(EĞER(B1:Z1=2;1;0)*SÜTUN(B1:Z1);2)-1))
 
Üst