boş hücreleri göz ardı ederek ortalama alma

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,351
Beğeniler
960
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#21
Son bir değişiklik yapdım,Sayın ataköylü-59 belirttiği gibi değerleri de düşürürseniz sanırım daha hızlı olur.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,351
Beğeniler
960
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#25
Fazla 9 ları attık.
 
Son düzenleme:
Katılım
15 Eylül 2015
Mesajlar
37
Beğeniler
3
Excel Vers. ve Dili
2007 - Türkçe
#26
Merhaba,
Denedim fakat bu olmuyor.
Deneme Dosya

Sorun yok ama uzun formülde de hız açısından bir sıkıntı yok. Sayıları 1000 yapınca yavaşlık çözüldü.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,351
Beğeniler
960
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#27
Aşağıdaki formülü dener misiniz?
Kod:
=ORTALAMA(KAYDIR($B$1;TOPLAMA(14;6;(SATIR($A$1:$A$1000)/($B$1:$B$1000<>""));SATIR($A$9))-1;;ARA(2;1/($B$1:$B$1000<>"");SATIR($B$1:$B$1000))))
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
25,182
Beğeniler
565
Excel Vers. ve Dili
OFFICE 2019 PRO TR
#28
Alternatif;

DİZİ formülüdür. CTRL+SHIFT+ENTER ile formül girişini tamamlayınız.

F3 Hücresine uygulayınız.

Kod:
=ROUND(AVERAGE(N(OFFSET(B$2;LARGE(IF(B$2:B$46<>0;ROW(B$2:B$46)-ROW(B$2));ROW($1:$9));0)));4)
Türkçesi;

Kod:
=YUVARLA(ORTALAMA(S(KAYDIR(B$2;BÜYÜK(EĞER(B$2:B$46<>0;SATIR(B$2:B$46)-SATIR(B$2));SATIR($1:$9));0)));4)
 
Katılım
15 Eylül 2015
Mesajlar
37
Beğeniler
3
Excel Vers. ve Dili
2007 - Türkçe
#31

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,351
Beğeniler
960
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#32
Ben bir sorun görmedim siz düzenleyiniz.Ortalama olarak
Formül 9 gün
Kod:
=ORTALAMA(KAYDIR($B$1;TOPLAMA(14;6;(SATIR($A$1:$A$1000)/($B$1:$B$1000<>""));SATIR($A$9))-1;;ARA(2;1/($B$1:$B$1000<>"");SATIR($B$1:$B$1000))))
Formül 14 gün
Kod:
=ORTALAMA(KAYDIR($B$1;TOPLAMA(14;6;(SATIR($A$1:$A$1000)/($B$1:$B$1000<>""));SATIR($A$14))-1;;ARA(2;1/($B$1:$B$1000<>"");SATIR($B$1:$B$1000))))
 
Son düzenleme:
Katılım
15 Eylül 2015
Mesajlar
37
Beğeniler
3
Excel Vers. ve Dili
2007 - Türkçe
#33
Ben bir sorun görmedim siz düzenleyiniz.Ortalama olarak
Merhaba,"
"TOPLAMA" formülü bende çıkmıyor. Ad hatası diyor. Onu "TOPLA" olarak değiştirdiğimde ise, "#SAYI/0!" sıfıra bölünme hatası alıyorum.
Dosya ektedir

Not: ekteki formülde başta B olarak kalmış onu da D olarak düzelttim fakat sonuç aynı.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,351
Beğeniler
960
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#34
Sayın Korhan AYHAN beyin formülünü kullanın.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,351
Beğeniler
960
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#35
Dosyanız.Formüller dizi formülü formülden çıkarken ctrl+ shift ve enter tuşlayınız.Başda { işareti sonda } işareti kendiliğinden oluşmalı
https://www.dosyaupload.com/atX2
 
Son düzenleme:
Katılım
15 Eylül 2015
Mesajlar
37
Beğeniler
3
Excel Vers. ve Dili
2007 - Türkçe
#36
Dosyanız.Formüller dizi formülü formülden çıkarken ctrl+ shift ve enter tuşlayınız.Başda { işareti sonda } işareti kendiliğinden oluşmalı
Merhaba,
Korhan Beyin formülü doğru sonuç vermedi fakat sizin formülünüzü uyguladım şu an hepsi doğru görünüyor. Formülde en sondaki 15 sayısı mevcut boşluklar dikkate alınarak mı yazıldı? Çünkü ileriki günlerde daha fazla boş hücre olabilir, bu doğru sonucu etkiler mi?

Gerçekten epey uğraştırdım sizi. Hakkınızı helal edin. İlginiz ve alakanız için çok teşekkürler :)
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,351
Beğeniler
960
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#37
Merhaba,
Korhan Beyin formülü doğru sonuç vermedi fakat sizin formülünüzü uyguladım şu an hepsi doğru görünüyor. Formülde en sondaki 15 sayısı mevcut boşluklar dikkate alınarak mı yazıldı? Çünkü ileriki günlerde daha fazla boş hücre olabilir, bu doğru sonucu etkiler mi?

Gerçekten epey uğraştırdım sizi. Hakkınızı helal edin. İlginiz ve alakanız için çok teşekkürler :)
10 ve 15 boşlukla ilgisi yok sabit.Satır kaydırma ile ilgili.ve son 9 ve 14 alma ile ilgili son 10 ortalama için 11,son 15 için 16 şeklinde düşününüz.
Rica ederim.Helal olsun.Dönüş yaptığınız için teşekkür ederim.
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
25,182
Beğeniler
565
Excel Vers. ve Dili
OFFICE 2019 PRO TR
#38
Merhaba,

Daha önce benimde böyle bir ortalamaya ihtiyacım olmuştu. Sağolsun Ali bey bir formül önermişti.

#28 nolu mesajımdaki formülü güncelledim. Tekrar deneyiniz.
 
Üst