Devrik Dönüşüm Formülü

firat131

Altın Üye
Altın Üye
Katılım
19 Ekim 2013
Mesajlar
13
Beğeniler
0
Excel Vers. ve Dili
Professional Plus 2016
#1
Ekran Alıntısı.PNG

Elimde ekran görüntüsünde soldaki tabloya benzer binlerce ürünlük satır var. Bu satırları aynı devrik dönüşüm yapıştırır gibi yandaki tabloya çevirmek istiyorum. Yani her ürünün bedenleri alt alta değil de yan yana yazacak. Tek tek kopyalayıp yatay yapıştırmak çok zaman alır. Bunun için bir kısayol var mıdır? Şimdiden teşekkür ederim. Örnek Excel ektedir.
 

Ekli dosyalar

EmrExcel16

Altın Üye
Altın Üye
Katılım
1 Kasım 2012
Mesajlar
257
Beğeniler
33
Excel Vers. ve Dili
Office 365 Türkçe
#4
Bu da olursa bu formülü kullanabilirsiniz
Kod:
=ÇOKEĞERSAY($A:$A;$G2;$B:$B;$H2;$C:$C;$I2;$D:$D;J$1)
 

firat131

Altın Üye
Altın Üye
Katılım
19 Ekim 2013
Mesajlar
13
Beğeniler
0
Excel Vers. ve Dili
Professional Plus 2016
#5
Bu da olursa bu formülü kullanabilirsiniz
Kod:
=ÇOKEĞERSAY($A:$A;$G2;$B:$B;$H2;$C:$C;$I2;$D:$D;J$1)
cevabınız için teşekkür ederim. bir hücrede güzel çalışıyor ancak yana doğru veya aşağı doğru çekince diğer hücrelerde formül kayıyor. Mesela G2 seçmesi gerekirken G3, G4 diye gidiyor. Bunu nasıl önlediniz siz? Elimdeki Exceli size göndersem inceleme şansınız olur mu?
 

asri

Altın Üye
Altın Üye
Katılım
24 Nisan 2005
Mesajlar
2,807
Beğeniler
79
Excel Vers. ve Dili
Office 2016 TR 64 Bit
#6
@EmrExcel16 formülüne ,

Beden bilgisi için IF (EĞER) eklemesi yapıldı.

Kod:
=IF(COUNTIFS($A:$A;$G2;$B:$B;$H2;$C:$C;$I2;$D:$D;J$1);J$1;"")
Kod:
=EĞER(ÇOKEĞERSAY($A:$A;$G2;$B:$B;$H2;$C:$C;$I2;$D:$D;J$1);J$1;"")
 

firat131

Altın Üye
Altın Üye
Katılım
19 Ekim 2013
Mesajlar
13
Beğeniler
0
Excel Vers. ve Dili
Professional Plus 2016
#7
@EmrExcel16 formülüne ,

Beden bilgisi için IF (EĞER) eklemesi yapıldı.

Kod:
=IF(COUNTIFS($A:$A;$G2;$B:$B;$H2;$C:$C;$I2;$D:$D;J$1);J$1;"")
Kod:
=EĞER(ÇOKEĞERSAY($A:$A;$G2;$B:$B;$H2;$C:$C;$I2;$D:$D;J$1);J$1;"")
cevabınız için teşekkür ederim. bir hücrede güzel çalışıyor ancak yana doğru veya aşağı doğru çekince diğer hücrelerde formül kayıyor. Mesela G2 seçmesi gerekirken G3, G4 diye gidiyor. Bunu nasıl önlediniz siz?
 

firat131

Altın Üye
Altın Üye
Katılım
19 Ekim 2013
Mesajlar
13
Beğeniler
0
Excel Vers. ve Dili
Professional Plus 2016
#8
Ben $ işaretini eksik koyuyordum. Kaydırırken değişmemesini bu sağlıyormuş. Cevaplarınız için tekrar çok teşekkür ederim sorunum çözüldü
 

EmrExcel16

Altın Üye
Altın Üye
Katılım
1 Kasım 2012
Mesajlar
257
Beğeniler
33
Excel Vers. ve Dili
Office 365 Türkçe
#9
@asri ekleme için teşekkur ederim.
Evet $ isareti hücrelerde sabitlemek için kullanilir ki siz zaten bunu deneme yanilma yöntemiyle ögrenmissiniz anladigim kadariyla.
Teşekkür içinde rica ederim iyi çalişmalar.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,616
Beğeniler
729
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#10
Dosyanız.
 

Ekli dosyalar

Üst