En son dolu hücrenin yanındaki sayı

ASLAN7410

Altın Üye
Altın Üye
Katılım
15 Temmuz 2012
Mesajlar
2,420
Excel Vers. ve Dili
Ofis 2013 Türkçe
Merhaba iyi akşamlar.

Ekte gönderdiğin excel dosyamda A sütununda sayılar mevcut B sütununda isimler mevcut.
Yapmak istediğim L3 hücresine, B sütunundaki en son dolu hücrenin solundaki A sütunundaki sayıyı almak istiyorum.

Bir türlü formülü oluşturamadım. Yardımcı olur musunuz?
 

Ekli dosyalar

Haluk

Özel Üye
Katılım
7 Temmuz 2004
Mesajlar
7,891
Excel Vers. ve Dili
32 Bit 2010 - İngilizce
Dizi formülü; (Ctrl+Shift+Enter)

Kod:
=MAX((B2:B5000<>"")*(A2:A5000))

Excel TR > MAX = MAK

.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,470
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
Deneyiniz.
Kod:
=İNDİS($A$1:$A$10000;TOPLA.ÇARPIM(MAK(($B$1:$B$10000<>"")*SATIR($A$1:$A$10000))))
 

ASLAN7410

Altın Üye
Altın Üye
Katılım
15 Temmuz 2012
Mesajlar
2,420
Excel Vers. ve Dili
Ofis 2013 Türkçe
Sayın Haluk Bey ilginiz için çok teşekkür ediyorum.

#AD? hatası verdi.
 

ASLAN7410

Altın Üye
Altın Üye
Katılım
15 Temmuz 2012
Mesajlar
2,420
Excel Vers. ve Dili
Ofis 2013 Türkçe
Sayın çıtır, sizinde ilginize çok teşekkür ediyorum.

İstediğim sonucu verdi, ellerinize sağlık.
Hayırlı geceler diliyorum.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,470
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
Sayın çıtır, sizinde ilginize çok teşekkür ediyorum.

İstediğim sonucu verdi, ellerinize sağlık.
Hayırlı geceler diliyorum.
Rica ederim.Dönüş yaptığınız için teşekkür ederim.Max yerine Mak yazarsanız ve dizi formülü uygularsanız Haluk beyin kodu da doğru sonuç verir.
 

ASLAN7410

Altın Üye
Altın Üye
Katılım
15 Temmuz 2012
Mesajlar
2,420
Excel Vers. ve Dili
Ofis 2013 Türkçe
Excel TR > MAX = MAK bunu diyorsanız okumuştum, ama anlamamıştım.
Kusura bakmayın, uyarınca farkettim, formülünüz ingilizceymiş.

Sizinde ellerinize sağlık, hayırlı geceler diliyorum.
 

Haluk

Özel Üye
Katılım
7 Temmuz 2004
Mesajlar
7,891
Excel Vers. ve Dili
32 Bit 2010 - İngilizce
Bu da alternatif;

TÜRKÇE:

Kod:
=DOLAYLI("A" & SATIR(KAYDIR(B1;BAĞ_DEĞ_DOLU_SAY(B:B)-1;0)))

İNGİLİZCE:

Kod:
=INDIRECT("A" & ROW(OFFSET(B1;COUNTA(B:B)-1;0)))

.
 
Katılım
1 Haziran 2014
Mesajlar
327
Excel Vers. ve Dili
Ofis 2010-Türkçe
Bir alternatifte benden olsun
=İNDİS(A2:A100;KAÇINCI(ARA(2;1/(B2:B100<>"");B2:B100);B2:B100;0))
 

ASLAN7410

Altın Üye
Altın Üye
Katılım
15 Temmuz 2012
Mesajlar
2,420
Excel Vers. ve Dili
Ofis 2013 Türkçe
Sorduğum bu soru için cevap veren herkese çok teşekkür ediyorum.
Herkesin ellerine sağlık, hayırlı günler diliyorum.
 
Üst