Excel Sayfası içinde arama

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Merhaba Excel Çalışma Kitabının içinde A - B - C - D Listesi var. Ben arama sayfası kısmına İsim soyisim ve No yazdığım zaman Listelerin hepsinde bütün sutunlarda isim soyisim, isim, soyisim, no araması yaptığında aynı değeri bulduğu zaman ünvan var yazmasını yoksa aramalarda ünvan yok yazmasını istiyorum bunun için nasıl birşey yapabiliriz. Teşekkür ederim
 

Ekli dosyalar

Son düzenleme:

Korhan Ayhan

Administrator
Yönetici
Admin
Katılım
15 Mart 2005
Mesajlar
41,178
Excel Vers. ve Dili
Microsoft 365 Tr-En 64 Bit
Merhaba,

Öncelikle linki inceleyip profilinizde gerekli düzeltmeyi yapmanızda fayda var.

 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Merhaba,

Öncelikle linki inceleyip profilinizde gerekli düzeltmeyi yapmanızda fayda var.

Teşekkür ederim. düzelttim.
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Tüm sayfalarda aramak istiyorum
 

Korhan Ayhan

Administrator
Yönetici
Admin
Katılım
15 Mart 2005
Mesajlar
41,178
Excel Vers. ve Dili
Microsoft 365 Tr-En 64 Bit
Deneyiniz.

C2:F2 hücrelerindeki boşluk karakterini silerek deneyiniz.

C3;
C++:
=EĞER(YADA(TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))=0;TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))=0);"ÜNVAN YOK";EĞER(TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))=TOPLA.ÇARPIM(($B3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")));"ÜNVAN VAR";"ÜNVAN YOK"))
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Deneyiniz.

C2:F2 hücrelerindeki boşluk karakterini silerek deneyiniz.

C3;
C++:
=EĞER(YADA(TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))=0;TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))=0);"ÜNVAN YOK";EĞER(TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))=TOPLA.ÇARPIM(($B3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")));"ÜNVAN VAR";"ÜNVAN YOK"))
Teşekkür ederim yalnız söyle bir durum var diğer listelerde sadece Beşiktaş yazdığı zaman da ünvan var yazsın
Birde Listeler aynı excel kitabının içinde değilde ayrı ayrı aynı klasörün içinde olsa olur mu?
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Beşiktaş Kartal ya da 19031903 şeklinde arandığı zamanda ünvan var yazsın istiyorum
 

Korhan Ayhan

Administrator
Yönetici
Admin
Katılım
15 Mart 2005
Mesajlar
41,178
Excel Vers. ve Dili
Microsoft 365 Tr-En 64 Bit
Dosyanızda iki kriter zorunluymuş gibi yazmışsınız.

Koşulları net belirtirseniz boşa vakit kaybı yaşamamış oluruz.

Sayfalar farklı dosyalardaysa makro kullanmanız daha uygun olacaktır..
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Dosyanızda iki kriter zorunluymuş gibi yazmışsınız.

Koşulları net belirtirseniz boşa vakit kaybı yaşamamış oluruz.

Sayfalar farklı dosyalardaysa makro kullanmanız daha uygun olacaktır..
Hem İsimden aransın, hem soyaddan aransın hemde Kimlik numarasından aransın istiyorum Bunlardan herhangi biri çıktığı zaman orda Ünvan var yazsın.
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
bazen No kısmında birşey yazmayabilir de
 

Korhan Ayhan

Administrator
Yönetici
Admin
Katılım
15 Mart 2005
Mesajlar
41,178
Excel Vers. ve Dili
Microsoft 365 Tr-En 64 Bit
Deneyiniz.

C++:
=EĞER(VE(TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))=0;TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))=0);"ÜNVAN YOK";EĞER(YADA(TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))>0;TOPLA.ÇARPIM(($B3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))>0);"ÜNVAN VAR";"ÜNVAN YOK"))
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Deneyiniz.

C++:
=EĞER(VE(TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))=0;TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))=0);"ÜNVAN YOK";EĞER(YADA(TOPLA.ÇARPIM(($A3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))>0;TOPLA.ÇARPIM(($B3=DOLAYLI("'"&C$2&"'!A1:K1000"))*SATIR(DOLAYLI("'"&C$2&"'!A1:K1000")))>0);"ÜNVAN VAR";"ÜNVAN YOK"))
Çok Teşekkür ederim. Ancak bazı sutunlarda aşağıda ki gibi listeler çıkıyor denediğim de ünvan var yazmadı

a) Beşiktaş Kartal
b) Kartal 1903
c) Fenerbahçe
d) Galatasaray
 

Korhan Ayhan

Administrator
Yönetici
Admin
Katılım
15 Mart 2005
Mesajlar
41,178
Excel Vers. ve Dili
Microsoft 365 Tr-En 64 Bit
EŞİTTİR mantığı ile arama yapar..
 

Korhan Ayhan

Administrator
Yönetici
Admin
Katılım
15 Mart 2005
Mesajlar
41,178
Excel Vers. ve Dili
Microsoft 365 Tr-En 64 Bit
Bu formül İÇERİR mantığı ile arama yapar..

C++:
=EĞER(VE(TOPLA.ÇARPIM(--ESAYIYSA(MBUL($A3;DOLAYLI("'"&C$2&"'!A1:K1000"))))=0;TOPLA.ÇARPIM(--ESAYIYSA(MBUL($B3;DOLAYLI("'"&C$2&"'!A1:K1000"))))=0);"ÜNVAN YOK";EĞER(YADA(TOPLA.ÇARPIM(--ESAYIYSA(MBUL($A3;DOLAYLI("'"&C$2&"'!A1:K1000"))))>0;TOPLA.ÇARPIM(--ESAYIYSA(MBUL($B3;DOLAYLI("'"&C$2&"'!A1:K1000"))))>0);"ÜNVAN VAR";"ÜNVAN YOK"))
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Bu formül İÇERİR mantığı ile arama yapar..

C++:
=EĞER(VE(TOPLA.ÇARPIM(--ESAYIYSA(MBUL($A3;DOLAYLI("'"&C$2&"'!A1:K1000"))))=0;TOPLA.ÇARPIM(--ESAYIYSA(MBUL($B3;DOLAYLI("'"&C$2&"'!A1:K1000"))))=0);"ÜNVAN YOK";EĞER(YADA(TOPLA.ÇARPIM(--ESAYIYSA(MBUL($A3;DOLAYLI("'"&C$2&"'!A1:K1000"))))>0;TOPLA.ÇARPIM(--ESAYIYSA(MBUL($B3;DOLAYLI("'"&C$2&"'!A1:K1000"))))>0);"ÜNVAN VAR";"ÜNVAN YOK"))
Çok Teşekkür ederim
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Merhaba Excel de A sutununda bulunan ünvanları Tarananlar sayfası A sutununda aramak istiyorum ama a sutunun yazılan unvanın ilk 10 karakterini aramak istiyorum bunun için nasıl bir formül uygulayabilirim
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Merhaba, örnek excelde Mesela
a. listesinde 1) BEŞİKTAŞ yazmasına rağmen ünvan var yazmıyor

Tc Kimlikde aynı şekilde size zahmet kontrol edebilir misiniz

benim istediğim İsim soyisim Listelerde arandığın da çıkarsa ünvan var yazması birde ayrıca TC no kısmından aranması


Mesela A listesinde D sütununda 1) Beşiktaş yazıyor ama benim listemde sadece Beşiktaş yazıyor burdan yakalayıp ünvan var çıkmasını istiyorum
 

Ekli dosyalar

Korhan Ayhan

Administrator
Yönetici
Admin
Katılım
15 Mart 2005
Mesajlar
41,178
Excel Vers. ve Dili
Microsoft 365 Tr-En 64 Bit
Formüle dikkat ederseniz $A3=... şeklinde ilerliyor..

Formüle göre ilerlediğimizde aşağıdaki denklem oluşur. Yani iki ifade birbirine EŞİT DEĞİLDİR. Sizin istediğiniz işlem için formülde İÇERİR mantığıyla arama koşulunu uygulamak gerekir.

BEŞİKTAŞ <> 1) BEŞİKTAŞ
 

bjk55

Altın Üye
Katılım
29 Mart 2010
Mesajlar
172
Excel Vers. ve Dili
TÜRKÇE - MİCROSOFT OFFİCE PROFESSİONAL PLUS 2021
Formüle dikkat ederseniz $A3=... şeklinde ilerliyor..

Formüle göre ilerlediğimizde aşağıdaki denklem oluşur. Yani iki ifade birbirine EŞİT DEĞİLDİR. Sizin istediğiniz işlem için formülde İÇERİR mantığıyla arama koşulunu uygulamak gerekir.

BEŞİKTAŞ <> 1) BEŞİKTAŞ
İçerir formülü ile aradığımda örnek Listede Beşiktaş Karataş yazıyor ama Benim aramak istediğim Beşiktaş Kara

Bu şekilde de Ünvan var yazıyor
 

Korhan Ayhan

Administrator
Yönetici
Admin
Katılım
15 Mart 2005
Mesajlar
41,178
Excel Vers. ve Dili
Microsoft 365 Tr-En 64 Bit
O zaman şöyle olabilir...

Önce TAM EŞLEŞME aranır, bulamazsa İÇERİR mantığıyla arama yapılır.
 
Üst