EXCELL ÇOKLU KOŞULA GÖRE FONKSİYON YAZMA

Katılım
23 Mart 2020
Mesajlar
13
Excel Vers. ve Dili
vba
Merhabalar. siparişler ve mal kabul diye iki tane sayfam var.İstediğim şey ,
siparişlerin A sütundaki değer,mal kabul sayfasındaki A sütununa eşitse ve mal kabul deki C sütunundaki tarih bugünün tarihinden büyükse ya da mal kabul sayfasının H sütunu 0 dan büyükse siparişlerdeki L sütunu "açık" yazsın değilse kapandı yazsın istiyorum.Ama mal kabuldeki H sütunu 0 dan büyükse, mal kabuldeki tarih bugünden küçük olsa bile hücreye açık yazdırsın istiyorum. Bu fonksiyonu yazdım ama hata veriyor. Yardımcı olursanız çok sevinirim.


=EĞER(Siparişler!A6='Mal Kabul'!A:A (VE('Mal Kabul'!C:C>BUGÜN() YADA('Mal Kabul'!H:H>0)));"AÇIK";"KAPANDI")
 

S.Yiğit

Destek Ekibi
Destek Ekibi
Katılım
1 Temmuz 2008
Mesajlar
1,627
Excel Vers. ve Dili
2016 TR
Merhaba,

Örnek tablo hazırlayarak tablo üzerinde açıklama yapıp eklerseniz yardımcı olmaya çalışalım, Ayrıca Forum genelinde büyük harfle yazma pek hoş karşılanmıyor ve forum kurallarına aykırıdır.
 
Katılım
23 Mart 2020
Mesajlar
13
Excel Vers. ve Dili
vba
Bilgilendirme için teşekkür ederim,büyük harfle yazdığımı fark etmemiştim kusura bakmayın.
Örnek dosyayı Drive'a yükledim. Bakabilirseniz çok sevinirim.
 

Ömer

Moderatör
Yönetici
Katılım
18 Ağustos 2007
Mesajlar
19,761
Excel Vers. ve Dili
2013-Türkçe
Merhaba

Deneyiniz.

=EĞER(A2="";"";EĞERHATA(EĞER(YADA(İNDİS('Mal Kabul'!H:H;KAÇINCI(A2;'Mal Kabul'!A:A;0))>0;İNDİS('Mal Kabul'!C:C;KAÇINCI(A2;'Mal Kabul'!A:A;0))>BUGÜN());"AÇIK";"KAPALI");"KAPALI"))

.
 
Katılım
23 Mart 2020
Mesajlar
13
Excel Vers. ve Dili
vba
Çok çok teşekkür ederimmm
 
Üst