Filtre ve Alttoplam hk.

Katılım
20 Şubat 2012
Mesajlar
113
Beğeniler
0
Excel Vers. ve Dili
Excel 2013 TR
#1
Merhaba arkadaşlar, makro ile filtre uyguladığım alan A5:A500 aralığı filtre uygulandığında örneğin A16:A48 aralığı listeleniyor ve alttoplam ile listelenen 1.satır ile son satırı hesaba dahil etmek istemiyorum. Yani filtre A16:A48 aralığını göstersin ama Alttoplam A17:A47 arasını hesaplasın istiyorum. Bunun için nasıl bir formül uygulamam gerekir acaba?
 

assenucler

Altın Üye
Altın Üye
Katılım
19 Ağustos 2004
Mesajlar
2,822
Beğeniler
54
Excel Vers. ve Dili
Office 365 Bireysel TR 32- Windows 10 Home x64 TR
#3
Örnek bir dosya eklerseniz, daha hızlı yanıt alabilirsiniz.
 
Katılım
20 Şubat 2012
Mesajlar
113
Beğeniler
0
Excel Vers. ve Dili
Excel 2013 TR
#4
Merhabalar, tarih filtresi uyguluyorum. Örneğin OCAK ayını süzdürüyorum fakat 01.01.2019 - 31.01.2019 şeklinde değil. 1gün öncesi ve 1 gün sonrasını da görmem gerekiyor. Bu nedenle 31.12.2018-01.02.2019 şeklinde makro ile filtreliyorum. Süzmede sorun yok. Ancak Alttoplam formülü ile ortalama almak istediğimde haliyle 31.12.2018-01.02.2019 aralığındaki değerlerin toplamını veriyor. Benim istediğim ise 01.01.2019-31.01.2019 arasını alsın. Bu diğer aylar için de geçerli.
 
Katılım
20 Şubat 2012
Mesajlar
113
Beğeniler
0
Excel Vers. ve Dili
Excel 2013 TR
#7
Bu şekilde kendinize göre revize ediniz.
Kod:
=ALTTOPLAM(9;D3:D19)
Merhabalar Seyit bey, vermiş olduğunuz formülü biliyor ve zaten kullanıyorum ama sorumu tam olarak anlatamamışım sanırım. Filtrelenen kısmın 1. ve sonuncu satırı alttoplama dahil edilmesin istemiştim. Fakat sorumu kendim çözdüm. A sütununa 1-2-3.... şeklinde sıra no verdim ve bu sıra noları da alttoplam ile min max alacak şekilde revize ettim. Süzme işlemini yapıp sırano+1 ve sırano-1 yapıp bunları da dolaylı formülü ile hücreye tanımladım. Sorunum çözüldü.
Kod:
=EĞERHATA(ALTTOPLAM(1;DOLAYLI(ADRES(ALTTOPLAM(5;$A$6:$A$372)+1;SÜTUN(E1);4)&":"&ADRES(ALTTOPLAM(4;$A$6:$A$372)-1;SÜTUN(E1);4)));"")
Sizin dışınızda cevap veren olmaması ise şaşırtıcı... Yine de cevap verme nezaketini gösterdiğiniz için teşekkür ederim Seyit bey sağolun.
 
Üst