Fonksiyon silinmesini engelleme

Erdinç FIRTINA

Altın Üye
Katılım
14 Şubat 2007
Mesajlar
364
Excel Vers. ve Dili
excel 2003 türkçe
Değerli üyeler;

=TOPLAM($E$2:$E$500) formülü ile M1 hücresine toplama işlemi yapıyorum. Ancak, toplama işleminden önce B2:B500 arasındaki boş olan hücre varsa satırları silmem gerekiyor. Bu durumda da formülde de değişiklik oluyor.

Örneğin; 150 satır siliniyorsa; =TOPLAM($E$2:$E$350) oluyor ve dolayısıyla toplama işlemini de istenilen şekilde yapmıyor. Satırlar silinse de formülün değişmemesi için nasıl bir işlem yapılmalıdır?

Ya da makro ile sorunu nasıl çözebilirim?
Yardımlarınız için şimdiden teşekkürler !!!
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,445
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
M1 Hücresine aşağıdaki formülü kopyalayınız.
Kod:
=TOPLA(DOLAYLI("E2:E500"))
 
Son düzenleme:
Üst