Geriye dönük sayma işlemi

Katılım
20 Eylül 2018
Mesajlar
72
Excel Vers. ve Dili
2016-Türkçe
Üstad tekrar merhaba.
Aşağıdaki eğerler tek başına çalıştırılınca sonuç veriyor. Bunları tek bir hücreye nasıl girilebileceğini biliyor musun acaba?

=EĞER(VE(TOPLA(BZ7;CA7)=0;CB7<=2);0;CB7-2)
=EĞER(VE(BZ7=0;TOPLA(CA7+CB7)<=2);0;CB7-1)
=EĞER(VE(BZ7=0;TOPLA(CA7+CB7)<=2);0;CB7)
=EĞER(TOPLA(BZ7;CA7;CB7)>=3;CA7-2+CB7;0)
=EĞER(VE(BZ7=1;TOPLA(CA7+CB7)<=2);0;CB7-2)
=EĞER(VE(BZ7>=1;CA7>=2;CB7<=2);CA7-1;CA7-1+CB7-2)
=EĞER(VE(BZ7>=2;TOPLA(CA7+CB7)<=2);0;CB7-2)
=EĞER(VE(BZ7>=2;CA7>=1;CB7<=2);CA7;CA7+CB7-2)
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
29,429
Excel Vers. ve Dili
OFFICE 2019 PRO TR
İnceleyiniz.

 
Katılım
20 Eylül 2018
Mesajlar
72
Excel Vers. ve Dili
2016-Türkçe
Son gönderdiğim dokumanda o formül var ve kullanılıyor.

formül (AAAA için yani 7. satır için)
=EĞER($H7<>"R";0;KAÇINCI(1;EĞER((($H7:$AL7<>"R")*($H$5:$AL$5<>""));1);0)-1)

H7 de R değeri yoksa 0 değilse ayın 1 inden itibaren peşpeşe kaç adet R varsa onu yazar....
Üstadım,
Bu formülde 31 çeken bir ayda, ayın 1 den 31 ine kadar R girilmişse sistem hata veriyor. Böyle bir durumda 31 i nasıl saydırırız?
 
Katılım
21 Aralık 2016
Mesajlar
344
Excel Vers. ve Dili
2013 TR
Üstadım,
Bu formülde 31 çeken bir ayda, ayın 1 den 31 ine kadar R girilmişse sistem hata veriyor. Böyle bir durumda 31 i nasıl saydırırız?
Evet... Ayın komplesinde R yazılmışsa, sonuç dizisinde 1 değeri olmayacak ve formül hata verecektir.
=EĞERHATA(KAÇINCI(1;EĞER((($H7:$AL7<>"R")*($H$5:$AL$5<>""));1);0)-1;GÜN(MAK($H$5:$AL$5)))
şeklinde yazabilirsiniz.

Not: Dokumanda H5:AL5 tarih mi yazıyordu, GÜN mü yazıyordu hatırlayamadım. GÜN şeklinde formüle edildiyse eğer GÜN(MAK($H$5:$AL$5)) yerine MAK($H$5:$AL$5) şeklinde yazarsınız.... DİZİ formüldür.
 
Son düzenleme:
Üst