Hücredeki kelimeyi baska hücrede sayısal olarak tarihe göre toplama

Katılım
25 Şubat 2016
Mesajlar
26
Beğeniler
1
Excel Vers. ve Dili
2007 türkçe
#1
Altalta sıralı hücrede belirlediğim kelimeler, belirli tarihlerde geçtiğinde, degeri 1 olacak ve o tarihe ait ay'ın altına toplarak yazılacak.
Yani aşağıdaki belirlediğim kelimeler A3 ve A13 arasındaki hücrelerden birine yazıldığında 1 değeri verecek, bu değer B3 ve B13 arasındaki tarihlerden hangisinde yazıldıysa o tarihe ait ay' a ait hücrede C2 ve F2 arasında toplanarak sonucu verecek
Opel
Kia
Jeep
Bmw
Alfa romeo
Audi
Porshe
Moto guzzi
Ducati
Mv agusta

Listeden herhangi bir değeri mesela; 01.01.2019 da A3 e ducati, 15.01.2019 da A4 e audi, 30.01.2019 da A5 e Bmw yazdığımda Bu listedeki her kelimenin değeri 1 olduğundan dolayı, Ocak ayı yani C3 hücresine toplanarak 3 değerini yazmasını istiyorum.
Örnek excel dosyası:
Yeni örnek
 
Son düzenleme:
Katılım
25 Şubat 2016
Mesajlar
26
Beğeniler
1
Excel Vers. ve Dili
2007 türkçe
#6
Emeğiniz icin tesekkurler ama böyle dememiştim. Yukarıda 10 adet marka var ya her bir markanın sayısal değer 1 olacak. 01.01.2019 15.01.2019 30.01.2019 tarihlerinde birer marka yazdığımda sağdaki ocak ayının altına bu üç markanın değerini toplayarak 3 yazacak her markanın sayısal değeri 1 olduğu için. Şubatta yazılan markalar içinde şubat ayı altına 3 yazacak. Anlatabildim umarım 😀
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,107
Beğeniler
889
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#7
Aynı marka ,aynı ay içersinde 1 den fazla yazıldığında 1 olarak mı toplayaçak ,yoksa her defa yazıldında bir olarak mı toplam alınaçak.Örnek
Ocak ayında Opel,Kia,Jeep,Opel,Opel,Kia sonucu= 6 mı yoksa 3 mü olaçak?
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
24,923
Beğeniler
495
Excel Vers. ve Dili
OFFICE 2019 PRO TR
#8
C3 hücresine uygulayıp deneyiniz.

Kod:
=TOPLA.ÇARPIM((METNEÇEVİR($B$3:$B$13;"aaaa")=C$2)*($A$3:$A$13<>""))
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
24,923
Beğeniler
495
Excel Vers. ve Dili
OFFICE 2019 PRO TR
#12
Deneyiniz.

Kod:
=TOPLA.ÇARPIM((METNEÇEVİR($B$3:$B$13;"aaaa")=D$2)*($A$3:$A$13=$C3))
 

gunay.harun

Altın Üye
Katılım
25 Şubat 2016
Mesajlar
26
Beğeniler
1
Excel Vers. ve Dili
2007 türkçe
#14
Deneyiniz.

Kod:
=TOPLA.ÇARPIM((METNEÇEVİR($B$3:$B$13;"aaaa")=D$2)*($A$3:$A$13=$C3))
Herkese selamlar, özelliklede Korhan beye.
Daha önce yardımcı olduğunuz formüle müdahale ettim fakat beceremedim. Yeni tabloma illerde eklendi.
Ekteki örnek dosyadan bana yardımcı olabilirmisiniz.
 
Üst