Hücreye hazır formülü atama

tamer42

Destek Ekibi
Destek Ekibi
Katılım
11 Mart 2005
Mesajlar
1,860
Excel Vers. ve Dili
Office 2013 İngilizce
Merhaba,

Hücreye bir satır ekleyince; bu satıra bir üstündeki satırda yazan formülleri nasıl atayabiliriz?
satırda bu şekilde bir formül yazılı olsun, altına boş bir satır eklediğimiz zaman, bu satırdaki formülleri eklenen satıra da koplayacak


"=ETOPLA('Eylül'!A:A;B12;'Eylül'!AF:AF)"

Kod:
Sub SATIR_EKLE()
    Dim SATIR As Long
    
    SATIR = [B65536].End(3).Row + 1
    Rows(SATIR).Insert Shift:=xlDown

End sub
teşekkürler, iyi çalışmalar.
 

ÖmerBey

Destek Ekibi
Destek Ekibi
Katılım
22 Ekim 2012
Mesajlar
3,320
Excel Vers. ve Dili
2007 Türkçe
Merhaba,
Kodunuzun sonuna ilave edip deneyiniz...
Kod:
For Each hcr In Intersect(ActiveSheet.UsedRange, Rows(SATIR - 1))
    If hcr.HasFormula Then hcr.Copy hcr.Offset(1)
Next
 
Son düzenleme:

tamer42

Destek Ekibi
Destek Ekibi
Katılım
11 Mart 2005
Mesajlar
1,860
Excel Vers. ve Dili
Office 2013 İngilizce
Merhaba,
Kodunuzun sonuna ilave edip deneyiniz...
Kod:
For Each hcr In Intersect(ActiveSheet.UsedRange, Rows(SATIR - 1))
    If hcr.HasFormula Then hcr.Copy hcr.Offset(1)
Next
Ömer Hocam bir sorun daha var, en üst satırda =TOPLA(E2:E13) şeklinde Toplam formülü mevcut, yeni bir satır eklendiği zaman bu formülü de düzenlememiz gerekecek. =TOPLA(E2:E14) şekline getirmeliyiz.

bu konuda da yardımcı olabilir misiniz

Teşekkürler,
iyi akşamlar.
 

ÖmerBey

Destek Ekibi
Destek Ekibi
Katılım
22 Ekim 2012
Mesajlar
3,320
Excel Vers. ve Dili
2007 Türkçe
Aşağıdaki iki kodu da kullanabilirsiniz...
Kod:
Range(xx).Formula = "=SUM(E2:E" & SATIR & ")"
Range(xx).FormulaLocal = "=TOPLA(E2:E" & SATIR & ")"
 

tamer42

Destek Ekibi
Destek Ekibi
Katılım
11 Mart 2005
Mesajlar
1,860
Excel Vers. ve Dili
Office 2013 İngilizce
Aşağıdaki iki kodu da kullanabilirsiniz...
Kod:
Range(xx).Formula = "=SUM(E2:E" & SATIR & ")"
Range(xx).FormulaLocal = "=TOPLA(E2:E" & SATIR & ")"
teşekkürler.
 
Üst