İki tarih aralığı toplam alma.

sward175

Altın Üye
Altın Üye
Katılım
4 Şubat 2011
Mesajlar
768
Excel Vers. ve Dili
Excel Vers. ve Dili:
OFFICE 2016 TÜRKÇE
Herkese iyi geceler,

İki tarih aralığındaki toplamı almak için aşağıdaki formülü yazdım, Fakat işlem yapmıyor.
Acaba satır çokluğundan ( yaklaşık 990000 satır) kaynaklı bir sorun mu bilemiyorum.
Kod yardımı ile bu konuyu aşabilmem için yardımlarınızı rica ederim.

Ekli dosyayı görüntüle 209990
 

sward175

Altın Üye
Altın Üye
Katılım
4 Şubat 2011
Mesajlar
768
Excel Vers. ve Dili
Excel Vers. ve Dili:
OFFICE 2016 TÜRKÇE
Herkese iyi geceler,
İki tarih aralığındaki toplamı almak için aşağıdaki formülü yazdım, Fakat işlem yapmıyor.
Acaba satır çokluğundan ( yaklaşık 990000 satır) kaynaklı bir sorun mu bilemiyorum.
Kod yardımı ile bu konuyu aşabilmem için yardımlarınızı rica ederim.
Saygılarımla,
sward175
 

Ekli dosyalar

askm

Altın Üye
Altın Üye
Katılım
4 Haziran 2005
Mesajlar
2,575
Excel Vers. ve Dili
2010-2016
TOPLA.ÇARPIM((($A$1:$A$990000=$H$1)*($B$1:$B$990000>=$G$4)*($B$1:$B$990000<=$H$4)*($D$1:$D$990000=$G$6)*($E$1:$E$990000<>"")))
Yukardaki şekilde formül doğru yalnız bu şarta uyan veri yok. Örnek olarak Abdullah Er i 01.01.2016 olarak ekledim. 1 Sonucunu verdi.
 

sward175

Altın Üye
Altın Üye
Katılım
4 Şubat 2011
Mesajlar
768
Excel Vers. ve Dili
Excel Vers. ve Dili:
OFFICE 2016 TÜRKÇE
Sayın, askm,

Formülü uyguluyorum fakat #YOK# hatası veriyor.
 

Mdemir63

Altın Üye
Katılım
7 Temmuz 2006
Mesajlar
1,889
Excel Vers. ve Dili
Excel-2003 Türkçe
Excel-2010 Türkçe
Selamlar
Aşağıdaki 3 alternatifi deneyiniz
Kod:
Çoketopla
=ÇOKETOPLA(C:C;B:B;">="&G4;B:B;"<="&H4;A:A;$H$1)
Kod:
Topla.Çarpım
=TOPLA.ÇARPIM((A:A=$H$1)*(B:B>=G4)*(B:B<=H4)*(C:C))
Kod:
Topla
CTRL+SHİFT+ENTER ile
=TOPLA((A:A=$H$1)*(B:B>=G4)*(B:B<=H4)*(C:C))
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
25,844
Excel Vers. ve Dili
OFFICE 2019 PRO TR
"C" sütunundaki değerlerin ne değeri olduğunu anlamadım. Başlıkları yok.

Kurduğunuz formülü aşağıdaki gibi düzenlerseniz sonuç alabilirsiniz.

Kod:
=TOPLA.ÇARPIM(($E$1:$E$990000=$H$1)*($B$1:$B$990000=$G$4)*($B$1:$B$990000=$H$4)*($D$1:$D$990000=G$6))
 

sward175

Altın Üye
Altın Üye
Katılım
4 Şubat 2011
Mesajlar
768
Excel Vers. ve Dili
Excel Vers. ve Dili:
OFFICE 2016 TÜRKÇE
Herkese Merhabalar,
Sayın, Mdemir63,
Sayın, Korhan Ayhan Hocamın,
Yazmış olduğu formülleri gerçek dosyaya uyguladım fakat sonuç 0 olarak çıkıyor.
Verilerin 990000 satır olması nedeni ile gerçek dosyayı yükleyemiyorum.
Bu bağlamda KOD yardımı ile bu hesaplamayı yapabilmem için yardımlarınızı rica ederim.
Saygılarımla,
sward175
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
8,288
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Örnek dosyanızda hiç 2016 verisi yok ama seçenek olarak 2016 yılını sorguluyorsunuz. Aynı zamanda tarih hücrelerine (G4:H4) de sadece 2016 sorgulaması yapılabiliyor.
 

sward175

Altın Üye
Altın Üye
Katılım
4 Şubat 2011
Mesajlar
768
Excel Vers. ve Dili
Excel Vers. ve Dili:
OFFICE 2016 TÜRKÇE
Yusuf Bey, Merhaba.
Asıl dosyada tarih 01.01.2014 ile 30.09.2019 arasında veriler bulunuyor ve bunlar yaklaşık 990000 satır.
Aşağıdaki formül ile yapmaya çalıştım olmadı.
Korhan hocamın ve Mdemir63 arkadaşın formülleri de çalışmadı. Bu formül doğrultusunda yardıma ihtiyacım bulunuyor.
=TOPLA.ÇARPIM(($E$1:$E$990000=$H$1)*($B$1:$B$990000=$G$4)*($B$1:$B$990000=$H$4)*($D$1:$D$990000=H$6)*(E7:E990006<>""))

Saygılar,
sward175
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
8,288
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Rich (BB code):
=TOPLA.ÇARPIM(($E$1:$E$990000=$H$1)*($B$1:$B$990000=$G$4)*($B$1:$B$990000=$H$4)*($D$1:$D$990000=H$6)*(E7:E990006<>""))
Önceki formülünüzde E200 olarak yazmıştınız, bu formülde de son kısmı yine farklı yazmışsınız. Kontrol aralığı her seçenek için aynı olmalı. Bir sütunda 10 satıra diğer sütunda 15 satıra bakılsın şeklinde olmaz.
 

sward175

Altın Üye
Altın Üye
Katılım
4 Şubat 2011
Mesajlar
768
Excel Vers. ve Dili
Excel Vers. ve Dili:
OFFICE 2016 TÜRKÇE
Yusuf Bey,
Vermiş olduğunuz formülü uyguladım.
Sonuç 0 olarak görünüyor, Kod yardımı bir butona bağlamak şartı ile yapma şansımız yok mu acaba?
Saygılar ,
sward175
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
8,288
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Ben bir formül vermedim, verdiğiniz formüldeki yanlışlığı gösterdim. Formülü düzgün kurduğunuzda doğru sonuç verecektir.
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
8,288
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Formülün doğru çalışıp çalışmadığını görmek için bize daha gerçeğe uygun bir dosya paylaşın lütfen.
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
8,288
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Formülü çok yanlış kurmuşsunuz.

=TOPLA.ÇARPIM(($D$1:$D$87602=$G$1)*($B$1:$B$87602=$F$4)*($B$1:$B$87602=$G$4)*($C$1:$C$87602=G$6)*(E1:E87602<>""))

Bu formülde D yani tür sütununda G6'nın karşılığını sorgulamanız gerekirken G4 yani başlangıç tarihini sorgulamışsınız.

Aynı şekilde B yani isimler sütununda H1'i sorgulamanız gerekirken F4'ü sorgulamışsınız, F4'te hiçbir şey yok.

Yine B sütununda bu sefer G4 yani başlama tarihini sorgulamışsınız.

Kısacası aradığınız şeyi yanlış yerlerde aramışsınız. Paylaştığınız dosyaya göre olması gereken formül şöyledir:

=TOPLA.ÇARPIM(($D$1:$D$87602=$G$6)*($B$1:$B$87602=$H$1)*($C$1:$C$87602>=$G$4)*($C$1:$C$87602<=$H$4)*($E$1:$E$87602<>""))
 

sward175

Altın Üye
Altın Üye
Katılım
4 Şubat 2011
Mesajlar
768
Excel Vers. ve Dili
Excel Vers. ve Dili:
OFFICE 2016 TÜRKÇE
Sayın, YUSUF44,
Teşekkür eder işlerinizde başarılar dilerim.
Saygılarımla,
sward175
 
Üst