Kalan Günü Bulma

Katılım
26 Nisan 2019
Mesajlar
8
Excel Vers. ve Dili
Office 2010
Merhaba,
Veri sayfasına c3:c aralığına rakamsal değer yazdığımda Sonuna (Gün) Yazdırabilir miyiz.

Ayrıca, Ana Sayfa da kırmızı sütunda skt tarihi var, Ürünlerin son kullanım tarihi yani,
Veri sayfasında da c3:c sütünda çekme süresi var buda her ürünün son kullanım tarihinden önce rafdan çekilmesi anlamındadır.
Şimdi ana sayfa d3:d ye giriş sayfasındaki tarihten, Veri sayfasındaki 3 gün de düşülerek kalan zamanı gün olarak yazdırmak istiyorum.
Örneğin 15 Gün kaldı Gibi
Yardımlarınız için Teşekkür ediyorum,
Örnek Dosya aşağıdaki linktedir.

örnek dosya
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
8,505
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Veri sayfasına c3:c aralığına rakamsal değer yazdığımda Sonuna (Gün) Yazdırabilir miyiz.
Bu hücreleri seçin ve hücre biçimlendirmeden isteğe uyarlanmış kısmını 0" Gün" olarak ayarlayın.

Şimdi ana sayfa d3:d ye giriş sayfasındaki tarihten, Veri sayfasındaki 3 gün de düşülerek kalan zamanı gün olarak yazdırmak istiyorum.
Ana sayfa D3 hücresine aşağıdaki formülü yazın:

=(DÜŞEYARA(A3;Giriş!$B$3:$D$300;3;0)-DÜŞEYARA(A3;Veri!$A$3:$C$300;3;0))-BUGÜN()&" gün kaldı"

Formüllerdeki 300 sayısını verilerinizin çokluğuna göre değiştirebilirsiniz.
 
Katılım
26 Nisan 2019
Mesajlar
8
Excel Vers. ve Dili
Office 2010
merhaba iyi akşamlar,
ilginiz için teşşekür ederim elinize sağlık. a3 hücresi boş olduğunda formülde #YOKyazıyor boş dursa daha estetik olurdu hani, ayrıca tarihi geçmiş ürünlere formül kaldı yerine atıyorum 3 gün geçti gibi de yazdırabilir miyiz. pek kullanılmayacak bi durum ama yine de önemli bir yeri olacaktır.

ilginize tekrardan teşekkür ediyorum. saglıklı mutlu geceler dilerim.
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
8,505
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Deneyiniz:

=EĞER(A3="";"";EĞER(DÜŞEYARA(A3;Giriş!$B$3:$D$300;3;0)<BUGÜN();"SKT "&BUGÜN()-DÜŞEYARA(A3;Giriş!$B$3:$D$300;3;0)&" gün geçti";EĞER(DÜŞEYARA(A3;Giriş!$B$3:$D$300;3;0)=BUGÜN();"SKT bugün";"Çekmeye "&(DÜŞEYARA(A3;Giriş!$B$3:$D$300;3;0)-DÜŞEYARA(A3;Veri!$A$3:$C$300;3;0))-BUGÜN()&" gün kaldı")))
 
Katılım
26 Nisan 2019
Mesajlar
8
Excel Vers. ve Dili
Office 2010
Merhaba Yusuf Bey
Denedim, lakin tutarsızlık var, Şöyleki örnek dosyaya ekledim -3 gün kaldı diyor.
bir başka örnekte ise 8 gün kaldı diyor yani -3 geçti demesi normal 8 gün kaldı demesi anarmol tarihi geçmişse illaki eksi olmalı yaklaşanlara kaldı demesi lazım. formulde düzenlemeyi yaptım ama olmadı.
yani tarihi yaklaşanlara kaldı, tarihi geçenlere geçti. bide son gün bugün ise skt bugün demesi gerekiyor. sizde bi kontrol edebilirseniz ayrıntıyı fark edeceksinizdir.. sanırım gözden kaçtı :)
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
8,505
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Ya formülü değiştirdiniz ya da dosya formatını değiştirdiniz. Örnek dosyanızda formül istediğiniz sonuçları veriyor. Şimdi formülü tekrar inceledim, bir hata göremedim.

Dosyayı hatalı haliyle paylaşır mısınız?
 
Katılım
25 Mayıs 2010
Mesajlar
157
Excel Vers. ve Dili
2016 Pro Plus TR
Ana Sayfa D3 e yapıştırın. Aşağı doğru çoğaltın.
Veri sayfasında C sütununa sadece rakam girin. ( yanına gün yazmayın)

Kod:
=EĞERHATA(EĞER(A3="";"";EĞER(((DÜŞEYARA(A3;Giriş!B:D;3;0)-DÜŞEYARA(A3;Veri!A:C;3;0))-BUGÜN())=0;"BUGÜN KALDIR";EĞER(((DÜŞEYARA(A3;Giriş!B:D;3;0)-DÜŞEYARA(A3;Veri!A:C;3;0))-BUGÜN())=1;"YARIN KALDIR";EĞER(((DÜŞEYARA(A3;Giriş!B:D;3;0)-DÜŞEYARA(A3;Veri!A:C;3;0))-BUGÜN())>1;((DÜŞEYARA(A3;Giriş!B:D;3;0)-DÜŞEYARA(A3;Veri!A:C;3;0))-BUGÜN())&" GÜN KALDI";EĞER(((DÜŞEYARA(A3;Giriş!B:D;3;0)-DÜŞEYARA(A3;Veri!A:C;3;0))-BUGÜN())<0;MUTLAK((DÜŞEYARA(A3;Giriş!B:D;3;0)-DÜŞEYARA(A3;Veri!A:C;3;0))-BUGÜN())&" GÜN GEÇTİ";"")))));"")
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
8,505
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Sayın leguminosea'nın Cevabıyla aklıma geldi: ben de dosyanızda gün yazmadan sadece sayı yazmıştım yanlış hatırlamıyorsam. Belki bahsettiğiniz hatanın sebebi budur.
 
Üst