Makro Vba

Katılım
9 Kasım 2020
Mesajlar
8
Excel Vers. ve Dili
excel 2017
Tablo aralık ayına kadar gidiyor.Soru şöyle: iki düğme oluşturun.İlk düğmede seçilen ay ,ikinci düğme seçilen aydan itibaren sonraki 3 ayın ortalamasını hesaplayacak. (Örnek Ocak seçildiyse Ocak,Şubat,MArt).Bunun makroda çözebilecek kodu nasıl yazabilirim
Aylar Harcamalar
ocak 345
şubat 567
mart 789
nisan 456
 

Mdemir63

Altın Üye
Katılım
7 Temmuz 2006
Mesajlar
2,043
Excel Vers. ve Dili
Excel-2010 Türkçe
Selamlar
Formumuza hoş geldiniz.
Sorularınızı örnek dosya ile desteklerseniz alacağınız yanıtlar çok daha çabuk olur.

Altın üye olmadığınız için örnek dosyanızı harici dosya sitelerine yükleyerek link paylaşabilirsiniz.

https://www.google.com/drive/
https://disk.yandex.com.tr/
https://onedrive.live.com/about/tr-tr/
https://www.dosyaupload.com/
http://dosya.co/
http://s2.dosya.tc/
https://wetransfer.com/
https://www.transfernow.net/tr/

ALTIN ÜYELİK
http://www.magaza.excel.web.tr/forum-uyelii/
FORUM KURALLARI
https://www.excel.web.tr/help/terms/
iyi çalışmalar
 

Mdemir63

Altın Üye
Katılım
7 Temmuz 2006
Mesajlar
2,043
Excel Vers. ve Dili
Excel-2010 Türkçe
Selamlar

E2 hücresine aşağıdaki formülü yapıştırın.
G2 hücresine ay ismi yazarak kontrol ediniz.

Kod:
=EĞER($G$2="Ocak";ORTALAMA(B2:B4);EĞER($G$2="Şubat";ORTALAMA(B3:B5);EĞER($G$2="Mart";ORTALAMA(B4:B6);EĞER($G$2="Nisan";ORTALAMA(B5:B7);EĞER($G$2="Mayıs";ORTALAMA(B6:B8);EĞER($G$2="Haziran";ORTALAMA(B7:B9);EĞER($G$2="Temmuz";ORTALAMA(B8:B10);EĞER($G$2="Ağustos";ORTALAMA(B9:B11);EĞER($G$2="Eylül";ORTALAMA(B10:B12);EĞER($G$2="Ekim";ORTALAMA(B11:B13);EĞER($G$2="Kasım";ORTALAMA(B12:B13;B2);EĞER($G$2="Aralık";ORTALAMA(B13;B2:B3);""))))))))))))
 
Üst