Soru metin içerisindeki rakamları toplama

Mesafe

Altın Üye
Katılım
29 Kasım 2011
Mesajlar
233
Excel Vers. ve Dili
Excel 2016 English
Merhaba,
bir hücre içerisinde düzenli olarak yazan metin ile birlikteki rakamları yine yanındaki hücreye yazılacak formül ile toplamak istiyorum.
 

Ekli dosyalar

Mahir64

Destek Ekibi
Destek Ekibi
Katılım
19 Nisan 2006
Mesajlar
5,715
Excel Vers. ve Dili
Excel 2013-Türkçe
Merhaba,
Deneyiniz.
DİZİ formülüdür.
Kod:
=TOPLA(EĞERHATA(--PARÇAAL(A1;SATIR(DOLAYLI("A1:A"&UZUNLUK(A1)));1);0))
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
10,174
Excel Vers. ve Dili
İş : Ofis 365 - Türkçe
Ev: Ofis 365 - Türkçe
Aşağıdaki kodları bir modüle kopyalayın:

PHP:
Private Function say(hucre As Range)
If hucre <> "" Then
    dizi = Split(hucre, " ")
    toplam = 0
    For i = 0 To UBound(dizi) - 1
        If IsNumeric(dizi(i)) Then
            toplam = toplam + dizi(i)
        End If
    Next
End If
say = toplam
End Function
Sonuç alacağınız hücrede =SAY(A1) şeklinde kullanabilirsiniz.
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
32,092
Excel Vers. ve Dili
Ofis 365 Tr-64 Bit
Ofis 2010 Tr-En 32 Bit
Alternatif;

Dosyanızda ki yapıya göre ondalıklı değerler varsa bunları da toplar.

Kullanım şekli ; =KTOPLA(A1;"+")


Boş bir modüle uygulayınız.

C++:
Option Explicit

Function KTOPLA(Veri As Range, Optional Ayıraç As String = "+")
    Dim Karakter As Variant
    Application.Volatile True
    With CreateObject("VbScript.RegExp")
        .Global = True
        .Pattern = "[^0-9," & Ayıraç & "]"
         Karakter = Replace(.Replace(Replace(Veri.Value, ".", ","), ""), ",", ".")
         KTOPLA = Evaluate(Karakter)
    End With
End Function
 

Mesafe

Altın Üye
Katılım
29 Kasım 2011
Mesajlar
233
Excel Vers. ve Dili
Excel 2016 English
yardımlarınız için çok teşekkürler
 

Mahir64

Destek Ekibi
Destek Ekibi
Katılım
19 Nisan 2006
Mesajlar
5,715
Excel Vers. ve Dili
Excel 2013-Türkçe
İyi çalışmalar.
 
Katılım
8 Temmuz 2020
Mesajlar
26
Excel Vers. ve Dili
2006 sürüm Türkçe
Denedim ama başarılı olamadım nerde hata yapıyorum acaba
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
32,092
Excel Vers. ve Dili
Ofis 365 Tr-64 Bit
Ofis 2010 Tr-En 32 Bit
Hangi çözümü denediniz?
 
Katılım
8 Temmuz 2020
Mesajlar
26
Excel Vers. ve Dili
2006 sürüm Türkçe
Merhaba,
Deneyiniz.
DİZİ formülüdür.
Kod:
=TOPLA(EĞERHATA(--PARÇAAL(A1;SATIR(DOLAYLI("A1:A"&UZUNLUK(A1)));1);0))
Sizin burada yazmış olduğunuz sadece rakamları getiriyor benim istediğim ise N5 VEYA F5 harf fark etmeksizin harfin içinde yazan rakamları yan yana toplayacak yanında N rakam yazmayanı saymadan toplayacak. Uğraştım yapamadım.
 
Katılım
8 Temmuz 2020
Mesajlar
26
Excel Vers. ve Dili
2006 sürüm Türkçe
Option Explicit

Function KTOPLA(Veri As Range, Optional Ayıraç As String = "+")
Dim Karakter As Variant
Application.Volatile True
With CreateObject("VbScript.RegExp")
.Global = True
.Pattern = "[^0-9," & Ayıraç & "]"
Karakter = Replace(.Replace(Replace(Veri.Value, ".", ","), ""), ",", ".")
KTOPLA = Evaluate(Karakter)
End With
End Function
Hangi çözümü denediniz?
Kod bölümüne yazdım ama sonuç alamadım arkadaşın sorduğu ve istediği nedir bilmiyorum benim istediğim ise şu yardımcı olursanız sevinirim.
N5 N5 N6 N8 N7 N1 N2 N N N N N N N3 N6 N8 Bunun gibi yan yana harf fark etmeksizin sadece harfin içindeki rakamları toplayım yazacak istediğim hücreye kısacası mesai toplamaya çalışıyorum.
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
32,092
Excel Vers. ve Dili
Ofis 365 Tr-64 Bit
Ofis 2010 Tr-En 32 Bit
Örnek dosya paylaşarak yapmak istediğiniz işlemi açıklar mısınız?

Dosya barındırma sitelerine örnek dosyanızı yükleyip linkini burada paylaşabilirsiniz.
 

Necdet

Moderatör
Yönetici
Katılım
4 Haziran 2005
Mesajlar
13,328
Excel Vers. ve Dili
Ofis 365 Türkçe
Sizin burada yazmış olduğunuz sadece rakamları getiriyor benim istediğim ise N5 VEYA F5 harf fark etmeksizin harfin içinde yazan rakamları yan yana toplayacak yanında N rakam yazmayanı saymadan toplayacak. Uğraştım yapamadım.
Mahir Bey'in verdiği formül, Dizi Formül, Siz formülü dizi formül olarak yani formülü yazdıktan sonra Ctrl+Shift+Enter ile girdiniz mi?
 
Üst