Soru Personel listesini çalışan bildirme listesine otomatik eklenmesi

Katılım
16 Nisan 2013
Mesajlar
3
Excel Vers. ve Dili
makro
Merhaba, 200 kişilik personel listesiniz linkteki çalışan bildirme formuna tek tek eklenmesi gerekiyor. Bunu makro ya da formulle nasıl yapabilirim? Her personel için tek tek form oluşturulması gerekiyor. Yardımcı olabilir misiniz? Yeni üye olduğum için dosya ekleyemiyorum.

çalışan bildirme formu
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
9,494
Excel Vers. ve Dili
İş : Ofis 365 - Türkçe
Ev: Ofis 365 - Türkçe
Personel listesi nerede? O listedeki hangi veri formdaki hangi alana gelecek?
 

aspava

Altın Üye
Altın Üye
Katılım
24 Nisan 2006
Mesajlar
93
Excel Vers. ve Dili
OFFICE 2019 Türkçe
Merhaba, 200 kişilik personel listesiniz linkteki çalışan bildirme formuna tek tek eklenmesi gerekiyor. Bunu makro ya da formulle nasıl yapabilirim? Her personel için tek tek form oluşturulması gerekiyor. Yardımcı olabilir misiniz? Yeni üye olduğum için dosya ekleyemiyorum.

çalışan bildirme formu
Sanırım Jandarma ' ya verilecek Ek 2 formunu düzenlemek istiyorsunuz ama personel verileri bu listenin içinde yok.
 
Katılım
6 Mart 2011
Mesajlar
133
Excel Vers. ve Dili
Microsoft Office 2010
Merhaba
İstemiş olduğunuz formu ben kullanıyorum. "Veri" tablosuna personellerin bilgilerini yazacaksın. "22-KİMLİK BİLDİRİMİ" tablosunda "P2" satırına kayıt ettiğin personelin sıra numarasını yazdığın zaman bütün kimlik bilgileri geliyor. Kırmızı ile renklendirdiğim alanlardaki veriler için
Kod:
=DÜŞEYARA(P2;Veri!A2:O2000;2;)
mantığı ile yapılmıştır.
..... Link .....
 
Katılım
16 Nisan 2013
Mesajlar
3
Excel Vers. ve Dili
makro

FORM

PERSONEL RAPORU SÜTUNU


TC. KİMLİK NO

TC Kimlik No


ADI SOYADI

Adı Soyadı


BABA ADI

Baba Adı


D.YERİ VE TARİHİ

Doğum Yeri / Doğum Tarihi


UYRUĞU

TC OLACAK


İŞİ

Görev


KONUT ADRESİ VE TELEFONU

Ev Adresi / Cep Telefonu


İŞE BAŞL.TARİHİ

Giriş Tarihi

 
Katılım
6 Mart 2011
Mesajlar
133
Excel Vers. ve Dili
Microsoft Office 2010
Üstte yazdığım şekilde yaptığın zaman işini görüyor mu?
 
Katılım
6 Mart 2011
Mesajlar
133
Excel Vers. ve Dili
Microsoft Office 2010
Kod:
Sub Toplu()
    Dim S1 As Worksheet, S2 As Worksheet, Son As Long
    
    Set S1 = Sheets("22-KİMLİK BİLDİRİMİ")
    Set S2 = Sheets("Veri")
    Son = S2.Cells(S2.Rows.Count, 1).End(3).Value
    
    For X = S1.Range("P2").Value To Son
        Range("P2").Value = X
        S1.PrintOut
    Next
    
    MsgBox "İşleminiz tamamlanmıştır.", vbInformation
End Sub
 
Üst