saat ve tarih damgası (bugün)

Katılım
14 Aralık 2011
Mesajlar
9
Beğeniler
0
Excel Vers. ve Dili
excel 97-2003
#1
merhaba dostlar
çalışma sayfasında b2 alanına bir veri girdiğimde a2 hücresine otm. tarih atıyor ancak exceli kapatıp ertesi gün açtığımda tarihi yine değişiyor yanşi ben işlemi yaptığımda veri girişi yapınca otm tarih atacak ancak bir daha değişeyecek şekilde nasıl ayarlarım

kullandığım formül şu şekilde
=EĞER(YADA(B2="");"";BUGÜN())
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
3,741
Beğeniler
452
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#6
B hücresine veri girdiğinizde A hücresine tarih atar ve değişmez.Bu işlemi B2:B4000 hücre aralığında işlem yaptığınızda yapar.Makro kodu.Sayfa kodu olarak kopyalayınız.
Kod:
Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Count > 1 Then Exit Sub
    If Intersect(Target, [B2:B4000]) Is Nothing Then Exit Sub
    If Target.Value <> "" Then
Target.Offset(0, -1) = Format(Now, "dd.mm.yyyy hh:mm:ss")
Else
Target.Offset(0, -1) = ""
End If
End Sub
 
Katılım
14 Aralık 2011
Mesajlar
9
Beğeniler
0
Excel Vers. ve Dili
excel 97-2003
#7
çok teşekkür ediyorum sizlere uğraş verdim Küçük bir ricada bulunsam
b2 değer girince a1 e tarih atacak diğer hücrelerden etkilenmemeli
excel çalışma kitabında 365 tane sayfam her sayfada sadece b2 değer girince a1 tarih atacak şekiklde düzenlerseniz müteşekkir olurum
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
3,741
Beğeniler
452
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#8
Çalışma kitabı kodu olarak kopyalayınız.
Kod:
Private Sub Workbook_SheetChange(ByVal Sh As Object, ByVal Target As Range)
If Target.Count > 1 Then Exit Sub
    If Intersect(Target, [B2]) Is Nothing Then Exit Sub
    If Target.Value <> "" Then
Range("A1")= Format(Now, "dd.mm.yyyy hh:mm:ss")
Else
Range("A1")= ""
End If
End Sub
 
Son düzenleme:
Üst