Soru SATIR DEĞERİ GETİRME

com5

Altın Üye
Katılım
15 Ocak 2019
Mesajlar
130
Beğeniler
7
Excel Vers. ve Dili
2016
#1
Merhaba

Güne göre personel çalışma raporu hazırlayacağım c1 satırındaki firmayı seçince o firmaya ait personellerin b2 + c2 + d2 +e2 otomatik gelmesini istiyorum. Bu mümkünmüdür.

Bana sadece personelin adı soyadını getirebileceğim birşey lazım.

1562871736746.png
 

Ekli dosyalar

Son düzenleme:

com5

Altın Üye
Katılım
15 Ocak 2019
Mesajlar
130
Beğeniler
7
Excel Vers. ve Dili
2016
#3
hocam tam olarak sanırım anlatamadım.

c1 hücresine firmayı seçince. Belirtilen firmadaki personellerin isimlerinin gelmesini istiyorum.

Kod:
=EĞERHATA(İNDİS('veri girişi'!$F$1:$F$2000;TOPLAMA(15;6;(SATIR($A$2:$A$2000)/(('veri girişi'!$A$2:$A$2000=$A3)*('veri girişi'!$D$2:$D$2000=$C$1)));SÜTUN(B$1)));"")
bu kod işime yaramadı malasef.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,116
Beğeniler
891
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#4
Neden örnek dosyada gayet güzel çalıştı.Siz ne arıyorsunuz da işinize yaramadı?
İlgili tarihde ve Firma isminde Personel var ise satıra getiriyor.Yok ise boş bırakıyor.
 
Son düzenleme:

com5

Altın Üye
Katılım
15 Ocak 2019
Mesajlar
130
Beğeniler
7
Excel Vers. ve Dili
2016
#5
hocam formülünüz çalışıyor ona lafım yok ama amacım dışında bir formül ben sadece firmalara ait personellerin ismini değişsin istiyorum

değişmesini istediğim yerleri sarıya boyadım. Yardım etmenizi ümit eder, şimdiden teşekkür ederim.

1562914723544.png
 

Ekli dosyalar

Son düzenleme:

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
7,707
Beğeniler
283
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
#6
Özet sayfasında B2 hücresine aşağıdaki formülü yazıp sağa doğru kopyalayın:

Kod:
=İNDİS(DOLAYLI($C$1);SÜTUN()-1)
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,116
Beğeniler
891
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#7
Sorunuz aşağıda Gün güme gitti.
Güne göre personel çalışma raporu hazırlayacağım c1 satırındaki firmayı seçince o firmaya ait personellerin b2 + c2 + d2 +e2 otomatik gelmesini istiyorum. Bu mümkünmüdür.
Hangi güne göre:Aşağıdaki tarihleri neden yazdınız?
 

com5

Altın Üye
Katılım
15 Ocak 2019
Mesajlar
130
Beğeniler
7
Excel Vers. ve Dili
2016
#8
Sorunuz aşağıda Gün güme gitti.
Güne göre personel çalışma raporu hazırlayacağım c1 satırındaki firmayı seçince o firmaya ait personellerin b2 + c2 + d2 +e2 otomatik gelmesini istiyorum. Bu mümkünmüdür.
Hangi güne göre:Aşağıdaki tarihleri neden yazdınız?

hocam gün boşa gitmedi. istediğim şey formülle mümkün ise günleri çoketopla ile farklı bir yöntemle yapacağım. sizi uğraştırmak istemedim. Sadece.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
5,116
Beğeniler
891
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#10
Sizi önce forumdaki diğer arkadaşlara havale ediyorum.Son.
 

com5

Altın Üye
Katılım
15 Ocak 2019
Mesajlar
130
Beğeniler
7
Excel Vers. ve Dili
2016
#11
Sizi önce forumdaki diğer arkadaşlara havale ediyorum.Son.
hocam neden bu şekilde cümleler kurduğunuzu anlamadım.
Daha önceden okadar yardımınız dokundu ki... hayranı olduğum birisisiniz.
Bu şekilde davranmanıza bir anlam veremedim. İlginç...
 

com5

Altın Üye
Katılım
15 Ocak 2019
Mesajlar
130
Beğeniler
7
Excel Vers. ve Dili
2016
#12
Özet sayfasında B2 hücresine aşağıdaki formülü yazıp sağa doğru kopyalayın:

Kod:
=İNDİS(DOLAYLI($C$1);SÜTUN()-1)

Hocam tekrar merhaba

bu formülde hatalı olan birşey var aslında formül tam istediğim gibi çalışıyor fakat hatalı çalışıyor


Örneğin Personel Listesi ( ad yönetici ile ) "hakan" olarak seçildi.
HAKAN 1
HAKAN 2
HAKAN 3
HAKAN 4
HAKAN 5
HAKAN 6
HAKAN 7
HAKAN 8
HAKAN 9
HAKAN 10

formülü kullandıktan sonra personel atlayarak geliyor.
Örneğin :
HAKAN 1
HAKAN 3
HAKAN 5
HAKAN 7
HAKAN 9


=İNDİS(DOLAYLI($C$1);SÜTUN()-1) bu şekilde girilince bu hatayı aldığımı yeni farkettim :) -1 değeri 0 ve +1 olarak değiştirdiğimde de aynı hatayı alıyorum. tabi farklı bir biçimde ...

yardımınızı rica ediyorum.
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
7,707
Beğeniler
283
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
#13
Muhtemelen özet sayfasında araya sütun eklemişsinizdir/hücre birleştirme yapmışsınızdır.
 

com5

Altın Üye
Katılım
15 Ocak 2019
Mesajlar
130
Beğeniler
7
Excel Vers. ve Dili
2016
#14
malasef birleştirme ve araya sütun ekleme gibi bir durum olmadı formül 1 kişi atlayarak gidiyor
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
7,707
Beğeniler
283
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
#15
Dosyayı hatalı haliyle paylaşır mısınız?
 

com5

Altın Üye
Katılım
15 Ocak 2019
Mesajlar
130
Beğeniler
7
Excel Vers. ve Dili
2016
#16
tabiiki; sorunu sanırım anladım. Hücreyi birleştirince hata veriyor. birleştirmeyince sorunsuz çalışıyor. Birleştirerek kullanabilirmiyim.

Örnek Birleştirmeyince ( sorunsuz çalışıyor )

1568619556051.png

Birleştirince sorun çıkıyor.
1568619593031.png
 

Ekli dosyalar

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
7,707
Beğeniler
283
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
#17
malasef birleştirme ve araya sütun ekleme gibi bir durum olmadı formül 1 kişi atlayarak gidiyor
tabiiki; sorunu sanırım anladım. Hücreyi birleştirince hata veriyor. birleştirmeyince sorunsuz çalışıyor. Birleştirerek kullanabilirmiyim.

Örnek Birleştirmeyince ( sorunsuz çalışıyor )

Ekli dosyayı görüntüle 209296

Birleştirince sorun çıkıyor.
Ekli dosyayı görüntüle 209297
Demek ki birleştirme varmış ;)

Şu şekilde deneyin:

=EĞERHATA(İNDİS(DOLAYLI($C$1);SÜTUN()/2);"")
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
7,707
Beğeniler
283
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
#18
Sorularınızı sorarken asıl dosyanızla aynı yapıda dosya paylaşmanız bunun için önemli. Çözümü bize verilen bilgilere ve örnek dosyaya göre hazırlıyoruz. Eğer farklı bir dosyada kullanacaksanız ya da sonradan dosya yapısında değişiklik yaparsanız bu hususa dikkat etmenizi rica ederim.
 
Üst