Sıra Numarası Düzenleme

etmeha

Altın Üye
Katılım
3 Haziran 2012
Mesajlar
32
Beğeniler
2
Excel Vers. ve Dili
excel2013 türkçe
#1
Arkadaşlar ;

Ekli dosyada ÖDEME sayfasında yenile dediğimde bazen 3. bazen 5. gibi farklı farklı satırları gizliyor. Satır gizleme yaptığında A:A sütunundaki sıra no karışıyor listenin kaç kişiden olduğunu anlamak için her defasında tek tek düzeltme yapmak zorunda kalıyorum . istediğim şey satır gizlenince sıra numarası alt satırdan saymaya devam etsin.
teşekkür ederim
 

Ekli dosyalar

Orion1

Uzman
Uzman
Katılım
1 Mart 2005
Mesajlar
21,786
Beğeniler
451
Excel Vers. ve Dili
Win7 Home Basic TR 64 Bit

Ofis-2010-TR 32 Bit
#2
Aşağıdaki gibi deneyin.:cool:
Rich (BB code):
Sub satgiz()
Application.ScreenUpdating = False
Rows.Hidden = False
son = Cells(65536, 2).End(xlUp).Row
For i = son To 1 Step -1
If Cells(i + 1, 5).Value = 0 Then Rows(i + 1).Hidden = True
Next
End Sub
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
7,704
Beğeniler
281
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
#3
A2 hücresinde aşağıdaki formülü kullanıp aşağı doğru kopyalayın:

Kod:
=EĞER([@[Ç.GÜN]]=0;"";MAK($A$1:A1)+1)
 

etmeha

Altın Üye
Katılım
3 Haziran 2012
Mesajlar
32
Beğeniler
2
Excel Vers. ve Dili
excel2013 türkçe
#4
Aşağıdaki gibi deneyin.:cool:
Rich (BB code):
Sub satgiz()
Application.ScreenUpdating = False
Rows.Hidden = False
son = Cells(65536, 2).End(xlUp).Row
For i = son To 1 Step -1
If Cells(i + 1, 5).Value = 0 Then Rows(i + 1).Hidden = True
Next
End Sub
olmadı üstadım
 
Katılım
3 Haziran 2012
Mesajlar
32
Beğeniler
2
Excel Vers. ve Dili
excel2013 türkçe
#6
A2 hücresinde aşağıdaki formülü kullanıp aşağı doğru kopyalayın:

Kod:
=EĞER([@[Ç.GÜN]]=0;"";MAK($A$1:A1)+1)
Üstat

=EĞER([@[Ç.GÜN]]=0;"";MAK($A$1:A1)+1)

verdiğin koda Ç.GÜNÜ YERİNE "DURUMU" 0 YERİNE "PASİF" YAZMAM GEREKTİĞİNDE

=EĞER([@[DURUMU]]="PASİF";"";MAK($A$1:A1)+1)
Bu şekilde yaptım ama kodu çalıştıramadım

işin özü AL hücresinde AKTİF yazıyorsa satır açık PASİF yazıyorsa gizli . ama gizlendiğinde bu kodu çalıştırıp nuamara sırasını düzeltemedim
 
Üst