Tarih Aralığına Göre Aylık Bazda Gün Saydırma

Katılım
10 Eylül 2020
Mesajlar
16
Excel Vers. ve Dili
Excel 2016 EN
Hepinize Merhabalar,

Bir konuda yardımıza ihtiyacım var, yardımcı olursanız çok mutlu olurum.
Ekteki excel dosyasında iki sayfa var.
Yapmak istediğim şey: Sheet1'deki E5 : P5 aralığına Sheet2'deki Kalem1'e denk gün sayılarını getirmek istiyorum. Ancak Sheet1'deki tarih aralığını kapsamayan(07.03.2019 - 15.05.2019) gün sayılarını.
Getirmek istediğim değerleri manuel olarak E5 : P5 aralığına ekledim

(Malesef dosyayı yükleyemedim platforma. o yüzden aşağı yapıştırmak zorunda kaldım
Şimdiden ayırdığınız vaktiniz için Teşekkürler.

[TABLE] 

Sheet1

              
                
  

Raporlama Tarih Başlangıcı

Raporlama Tarih Sonu

Ocak

Şubat

Mart

Nisan

Mayıs

Haziran

Temmuz

Ağustos

Eylül

Ekim

Kasım

Aralık


 

Kalem1

07.03.2019​

15.05.2019​

31​

28​

24​

0​

16​

30​

31​

31​

30​

31​

30​

31​


                
                [/TABLE]

[TABLE] 

Sheet2

              
                
                
 

Kalem1

21.01.2019​

31.12.2019​

            
 

Kalem2

15.03.2019​

27.09.2019​

            
                
                [/TABLE]

Saygılar
Murat
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
9,708
Excel Vers. ve Dili
İş : Ofis 365 - Türkçe
Ev: Ofis 365 - Türkçe
Merhaba, foruma hoş geldiniz.

Sizin de göreceğiniz üzere tablo olarak yapıştırmak forumda istenen sonucu vermiyor.

Dosyanızı imzamda belirttiğim şekilde başka sitelere yükleyip burada paylaşabilirsiniz. Dosyanız excel dosyası olursa ve içinde istediğiniz sonuca dair örnek olursa çözüme ulaşmak daha kolay olur.
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
9,708
Excel Vers. ve Dili
İş : Ofis 365 - Türkçe
Ev: Ofis 365 - Türkçe
Açıkçası ne yapmak istediğinizi anlamadım. Örneğin 1. sayfada Ocak altında neden 31 yazıyor? İstediğiniz sonucun neden öyle olması gerektiğini açıklar mısınız? Daha açık bir ifadeyle bu dosyayı manuel olarak oluşturmak isteseydik sırasıyla hangi işlemleri yapmamız gerekirdi?
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
9,708
Excel Vers. ve Dili
İş : Ofis 365 - Türkçe
Ev: Ofis 365 - Türkçe
Yapamadım maalesef.
 
Katılım
10 Eylül 2020
Mesajlar
16
Excel Vers. ve Dili
Excel 2016 EN
Korhan Bey Cevabınız için çok teşekkür ederim.
İki çözümünüzde işe yarıyor. Ancak ben formulün içinde bir de Vlookup benzeri birşey de istiyorum. Kalem1 ürününü diğer sayfada ara ve formulüle et gibi.

Çok Teşekkürler Şimdiden

Murat
 
Katılım
10 Eylül 2020
Mesajlar
16
Excel Vers. ve Dili
Excel 2016 EN
Ayrıca sanırım siz Sheet2'ye bakmadan formülü çalıştırmışınız.
Mesela Sheet''deki Kalem1'in periyodunu 26.03.2019 - 01.05.2019 olarak değiştirirsem sonuçların Mart:5 Nisan:30 ve Mayıs1 olması lazım.

Murat
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
9,708
Excel Vers. ve Dili
İş : Ofis 365 - Türkçe
Ev: Ofis 365 - Türkçe
Ayrıca sanırım siz Sheet2'ye bakmadan formülü çalıştırmışınız.
Mesela Sheet''deki Kalem1'in periyodunu 26.03.2019 - 01.05.2019 olarak değiştirirsem sonuçların Mart:5 Nisan:30 ve Mayıs1 olması lazım.

Murat
Korhan Bey'in ilk formülünü aşağıdakiyle değiştirip dener misiniz?

=TOPLA.ÇARPIM(--(METNEÇEVİR(SATIR(DOLAYLI(MAK(DÜŞEYARA($B5;Sheet2!$B$5:$D$20;2;0);$C5)+1&":"&MİN(DÜŞEYARA($B5;Sheet2!$B$5:$D$20;3;0);$D5)));"aaaa")=E$4))
 
Katılım
21 Aralık 2016
Mesajlar
256
Excel Vers. ve Dili
2013 TR
Selamlar,
Alternatif olarak....
Çeşitlilik olması amacıyla hazırlanan dokuman Ektedir... İncelersiniz....
Not : Listede aynı kalemlerden birden fazla olabilmesi durumu ele alındı.

 
Katılım
10 Eylül 2020
Mesajlar
16
Excel Vers. ve Dili
Excel 2016 EN
Yusuf Öncelikle Teşekkürler,

Formül çalıştı ancak eksiklik var. Aşağıdaki linkte Sheet'deki tarih aralığını değiştirince formülün tam çalışmadığı görüldü.
Yazılacak maksimum gün sayısı Sheet1'deki aralığı geçmemesi gerekiyor.


İyi Çalışmalar
Murat
 
Katılım
10 Eylül 2020
Mesajlar
16
Excel Vers. ve Dili
Excel 2016 EN
Selamlar,
Alternatif olarak....
Çeşitlilik olması amacıyla hazırlanan dokuman Ektedir... İncelersiniz....
Not : Listede aynı kalemlerden birden fazla olabilmesi durumu ele alındı.

Teşekkürler Eline sağlık. Güzel olmuş. Data sayfasında oynamam yapmam mümkün olmadığından kullanamayacagım ancak başka arkadaşların işine yaracaktır.

İyi Çalışmalar
Murat
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
9,708
Excel Vers. ve Dili
İş : Ofis 365 - Türkçe
Ev: Ofis 365 - Türkçe
Korhan Bey'in formülündeki "+1"in fonksiyonunu çözemedim. Onu kullanmadan aşağıdaki şekilde doğru sonucu veriyor gibi:

=EĞER(YADA($C5>DÜŞEYARA($B5;Sheet2!$B$5:$D$20;3;0);$D5<DÜŞEYARA($B5;Sheet2!$B$5:$D$20;2;0));0;TOPLA.ÇARPIM(--(METNEÇEVİR(SATIR(DOLAYLI(MAK(DÜŞEYARA($B5;Sheet2!$B$5:$D$20;2;0);$C5)&":"&MİN(DÜŞEYARA($B5;Sheet2!$B$5:$D$20;3;0);$D5)));"aaaa")=E$4)))
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
9,708
Excel Vers. ve Dili
İş : Ofis 365 - Türkçe
Ev: Ofis 365 - Türkçe
Anladığım kadarıyla şöyle olacak Korhan Bey; her iki sayfada başlangıç değerlerinden büyük olanla, bitiş değerlerinden küçük olan arasına denk gelen gün sayıları tabloya işlenecek.

Örneğin birinci sayfada Kalem1 için başlangıç tarihi 07/01/2019 ve bitiş tarihi 15/05/2019 iken ikinci sayfada sırasıyla 28/10/2019 ve 01/11/2019 tarihleri var. birinci sayfadaki bitiş tarihi ikinci sayfadaki başlangıç tarihinden önce olduğundan, hiçbir kesişim olmaması nedeniyle tüm aylar 0 olacak.

Eğer ikinci sayfadaki başlangıç tarihi 01/04/2019 olsaydı tabloda 01/04/2019 ile 15/05/2019 tarihleri arası işlenecek ve nisan için 30; mayıs için 15 yazılacaktı.

Verdiğiniz örnekte başlangıç tarihleri 01/01/2019-07/01/2019 ve bitiş tarihleri 30/04/2019-15/05/2019 olduğundan; başlangıç tarihlerinin büyüğü olan 07/01/2019 ve bitiş tarihlerinin küçüğü olan 30/04/2019 arasının işlenmesi gerekiyor. Bu durumda ocak için 31-6=25, şubat için 28, mart için 31 ve nisan için de 30 olması; diğer ayların 0 olması gerekiyor.
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
28,164
Excel Vers. ve Dili
OFFICE 2019 PRO TR
Alternatif;

Bazı denemeler yaptım.Sanki düzgün çalışıyor gibi göründü. Deneyip bilgi verirseniz sevinirim.

C++:
=MİN(TOPLA.ÇARPIM(--(METNEÇEVİR(SATIR(DOLAYLI($C5+1&":"&$D5));"aaaa")=E$4));TOPLA.ÇARPIM(--(METNEÇEVİR(SATIR(DOLAYLI(DÜŞEYARA($B5;Sheet2!$B:$D;2;0)+1&":"&DÜŞEYARA($B5;Sheet2!$B:$D;3;0)));"aaaa")=E$4)))
 
Üst