Userform textboxa devamlı sayaç koyma

byfika

Altın Üye
Altın Üye
Katılım
15 Ağustos 2009
Mesajlar
224
Excel Vers. ve Dili
2003 + 2007 + 2016
Merhabalar, userform textbox ve comboboxlarla kaydet, bul, düzelt ve sil kodları ile A-U sütunları arası A2 den itibaren veri girilip, A2:A65536 arasındaki dolu satırlar aşağıdaki kodla sayılmakta. Veri silinince sayı düşmekte. satır verisi veya birden fazla satır verisi silinse dahi girilen son veride aldığı sayıda kalacak satıra veri girildikçe kaldığı yerden devam edecek sayaç yapmak mümkün mü?
Bilgi için şimdiden teşekkürler...

Private Sub UserForm_Initialize()
TextBox1.Text = WorksheetFunction.CountA(Sayfa1.Range("A2:A65535"))
End Sub
 

Ekli dosyalar

systran

Destek Ekibi
Destek Ekibi
Katılım
15 Aralık 2007
Mesajlar
1,561
Excel Vers. ve Dili
2007 [TR], 2013 [TR]
şu formülü deneyin.
Edit:
WorkBook Open olayına şu kodu ekleyin. Sayfa1.Range("AA1").Value = Sayfa1.Range("A65535").End(xlUp).Row + 1
Form initialize olayına şu kodu ekleyin. textbox1.text=sayfa1.range("AA1")
 
Son düzenleme:

byfika

Altın Üye
Altın Üye
Katılım
15 Ağustos 2009
Mesajlar
224
Excel Vers. ve Dili
2003 + 2007 + 2016
Merhabalar, yanıtınız yeni gördüm. Kodları uyguladığımda çalıştıramadım. Yanıtınız için teşekkürler.
Saygılarımla...

alttaki gibi bir işlem yapıp problemi çözdüm.

AK1 hücresine =EĞER(A2="";0;BÜYÜK(A2:A65536;1))

Private Sub UserForm_Initialize()
TextBox1.Text = Sayfa1.Range("AK1")
End Sub
 

systran

Destek Ekibi
Destek Ekibi
Katılım
15 Aralık 2007
Mesajlar
1,561
Excel Vers. ve Dili
2007 [TR], 2013 [TR]
En sevdiğim...
kendi problemini kendi çözen. :D
 
Üst