Yer değiştirme

Katılım
28 Ekim 2009
Mesajlar
21
Excel Vers. ve Dili
Excel 2019 Tr
merhaba
a sütununda ingilizce kelimeler var.
çıktı alıp çalışıyorum.
ancak hep aynı sıra ile çalışmak olmuyor.
bunların yerini değiştirmek istiyorum.
ardından tekrar çıktı alıp çalışmak için.
nasıl yapılabilir acaba. (1000 kelime)
 
Katılım
28 Ekim 2009
Mesajlar
21
Excel Vers. ve Dili
Excel 2019 Tr
1000 kelimeye kadar yerdeğitirme olabiliyor. bazen 75 kelime oluyor, bazen 1000.
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
7,920
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Makro olmadan şu basit çözümü deneyebilirsiniz:

B1 hücresine

=RASTGELEARADA(1;BAĞ_DEĞ_DOLU_SAY(A:A))

Formülünü yazın ve aşağı doğru kopyalayın.

B sütununda herhangi bir hücreyi seçin ve Veri menüsünden küçükten büyüğe sıralama düğmesine basın. Bu düğmeye her bastığınızda sıralamalar değişecektir.
 
Katılım
28 Ekim 2009
Mesajlar
21
Excel Vers. ve Dili
Excel 2019 Tr
Makro olmadan şu basit çözümü deneyebilirsiniz:

B1 hücresine

=RASTGELEARADA(1;BAĞ_DEĞ_DOLU_SAY(A:A))

Formülünü yazın ve aşağı doğru kopyalayın.

B sütununda herhangi bir hücreyi seçin ve Veri menüsünden küçükten büyüğe sıralama düğmesine basın. Bu düğmeye her bastığınızda sıralamalar değişecektir.
merhaba
bu formülde sonuç olarak rakam çıkıyor.
 
Katılım
28 Ekim 2009
Mesajlar
21
Excel Vers. ve Dili
Excel 2019 Tr
üstadım tamamdır.

çıkan rakamı düşey ara formülü ile listeden istediğim yere çekerek her sıralamaya tıklandığında liste değişiyor.

sonuçta ortaya çıkan formül

=DÜŞEYARA(RASTGELEARADA(1;BAĞ_DEĞ_DOLU_SAY('ana-liste'!B2:B800));'ana-liste'!A2:E80;2;YANLIŞ)

çok teşekkürler
 
Katılım
28 Ekim 2009
Mesajlar
21
Excel Vers. ve Dili
Excel 2019 Tr
fakat aynı kelimeden birden fazla sayıda geliyor.
eşsiz olmasını nasıl sağlarız acaba?
 

YUSUF44

Destek Ekibi
Destek Ekibi
Katılım
4 Ocak 2006
Mesajlar
7,920
Excel Vers. ve Dili
İş : Ofis 2016 - Türkçe
Ev: Ofis 2016 - Türkçe
Verdiğim formül için ayrıca işlem yapmanıza gerek yoktu ki! Bu haliyle her sıralamada ayrı şekilde sıralama yapıp farklı sorular getirir zaten. A sütununda sorular B sütununda da bu formül olacak, B sütununa göre sıralama yapacaksınız.
 
Üst